aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-FastCGI
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-FastCGI')
-rw-r--r--www/p5-FastCGI/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/www/p5-FastCGI/Makefile b/www/p5-FastCGI/Makefile
index 0d0e3b148b80..5284b84cded6 100644
--- a/www/p5-FastCGI/Makefile
+++ b/www/p5-FastCGI/Makefile
@@ -5,23 +5,25 @@
# $FreeBSD$
#
-PORTNAME= p5-FastCGI
+PORTNAME= FastCGI
PORTVERSION= 0.52
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= FCGI
DISTNAME= FCGI-${PORTVERSION}
+PKGNAMEPREFIX= p5-
MAINTAINER= kbyanc@posi.net
BUILD_DEPENDS= ${LOCALBASE}/lib/libfcgi.a:${PORTSDIR}/www/fcgi
-USE_PERL5= YES
+USE_PERL5= yes
MAN3= FCGI.3
MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
do-configure:
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL)
+ @cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${PERL5} Makefile.PL \
+ CC="${CC}" CCFLAGS="${CFLAGS}"
.include <bsd.port.mk>