aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-Net-STF-Client/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-Net-STF-Client/Makefile')
-rw-r--r--www/p5-Net-STF-Client/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/www/p5-Net-STF-Client/Makefile b/www/p5-Net-STF-Client/Makefile
new file mode 100644
index 000000000000..26a8d1ecfbc1
--- /dev/null
+++ b/www/p5-Net-STF-Client/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: Net::STF::Client
+# Date created: 03 Jan 2012
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Net-STF-Client
+PORTVERSION= 1.00
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension for STF Client
+
+RUN_DEPENDS= \
+ p5-Class-Accessor-Lite>0:${PORTSDIR}/devel/p5-Class-Accessor-Lite \
+ p5-Furl>0:${PORTSDIR}/www/p5-Furl \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww \
+ p5-URI>0:${PORTSDIR}/net/p5-URI
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Net::STF::Bucket.3 \
+ Net::STF::Client.3 \
+ Net::STF::Object.3
+
+.include <bsd.port.mk>