aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WWW-OpenSearch/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WWW-OpenSearch/Makefile')
-rw-r--r--www/p5-WWW-OpenSearch/Makefile25
1 files changed, 15 insertions, 10 deletions
diff --git a/www/p5-WWW-OpenSearch/Makefile b/www/p5-WWW-OpenSearch/Makefile
index faa295d6cd3f..b39f55465063 100644
--- a/www/p5-WWW-OpenSearch/Makefile
+++ b/www/p5-WWW-OpenSearch/Makefile
@@ -6,29 +6,34 @@
#
PORTNAME= WWW-OpenSearch
-PORTVERSION= 0.05
+PORTVERSION= 0.08
CATEGORIES= www perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= WWW
PKGNAMEPREFIX= p5-
-MAINTAINER= gslin@gslin.org
+MAINTAINER= perl@FreeBSD.org
COMMENT= Search A9 OpenSearch compatible engines
-BUILD_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/XML/LibXML.pm:${PORTSDIR}/textproc/p5-XML-LibXML \
- ${SITE_PERL}/Data/Page.pm:${PORTSDIR}/databases/p5-Data-Page \
- ${SITE_PERL}/LWP.pm:${PORTSDIR}/www/p5-libwww \
- ${SITE_PERL}/XML/RSS/LibXML.pm:${PORTSDIR}/textproc/p5-XML-RSS-LibXML
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= p5-Data-Page>=2.00:${PORTSDIR}/databases/p5-Data-Page \
+ p5-libwww>=5.60:${PORTSDIR}/www/p5-libwww \
+ ${SITE_PERL}/URI.pm:${PORTSDIR}/net/p5-URI \
+ p5-XML-Feed>=0.08:${PORTSDIR}/textproc/p5-XML-Feed \
+ p5-XML-LibXML>=1.58:${PORTSDIR}/textproc/p5-XML-LibXML
PERL_CONFIGURE= yes
-MAN3= WWW::OpenSearch.3
+MAN3= WWW::OpenSearch.3 \
+ WWW::OpenSearch::Description.3 \
+ WWW::OpenSearch::Image.3 \
+ WWW::OpenSearch::Query.3 \
+ WWW::OpenSearch::Response.3 \
+ WWW::OpenSearch::Url.3
.include <bsd.port.pre.mk>
-.if ${PERL_LEVEL} < 500703 # inherited from textproc/p5-XML-RSS-LibXML
-IGNORE= requires perl 5.7.3 or later. Install lang/perl5.8 then try again
+.if ${PERL_LEVEL} < 500701
+IGNORE= requires perl 5.7.1 or later. Install lang/perl5.8 then try again
.endif
.include <bsd.port.post.mk>