aboutsummaryrefslogtreecommitdiffstats
path: root/www/p5-WebService-Linode/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/p5-WebService-Linode/Makefile')
-rw-r--r--www/p5-WebService-Linode/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/www/p5-WebService-Linode/Makefile b/www/p5-WebService-Linode/Makefile
index 2b74d9b7c7de..ea99dd922563 100644
--- a/www/p5-WebService-Linode/Makefile
+++ b/www/p5-WebService-Linode/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= WebService-Linode
-PORTVERSION= 0.11
+PORTVERSION= 0.13
CATEGORIES= www
MASTER_SITES= CPAN
MASTER_SITE_SUBDIR= WebService
@@ -14,16 +14,18 @@ COMMENT= Perl Interface to the Linode.com API
LICENSE= ART10 GPLv1
LICENSE_COMB= dual
-RUN_DEPENDS= p5-Crypt-SSLeay>0:${PORTSDIR}/security/p5-Crypt-SSLeay \
- p5-JSON>0:${PORTSDIR}/converters/p5-JSON \
- p5-libwww>0:${PORTSDIR}/www/p5-libwww
+BUILD_DEPENDS= p5-Crypt-SSLeay>=0:${PORTSDIR}/security/p5-Crypt-SSLeay \
+ p5-JSON>=0:${PORTSDIR}/converters/p5-JSON \
+ p5-libwww>=0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS:= ${BUILD_DEPENDS}
+TEST_DEPENDS= p5-Test-MockObject>=0:${PORTSDIR}/devel/p5-Test-MockObject
+NO_STAGE= yes
USES= perl5
-USE_PERL5= configure
+USE_PERL5= modbuildtiny
MAN3= WebService::Linode.3 \
WebService::Linode::Base.3 \
WebService::Linode::DNS.3
-NO_STAGE= yes
.include <bsd.port.mk>