aboutsummaryrefslogtreecommitdiffstats
path: root/www/peacock/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/peacock/Makefile')
-rw-r--r--www/peacock/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/www/peacock/Makefile b/www/peacock/Makefile
index c7c613af7ec6..50911a02c15c 100644
--- a/www/peacock/Makefile
+++ b/www/peacock/Makefile
@@ -26,4 +26,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib" \
GTK_CONFIG="${GTK_CONFIG}"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>