aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-cherrypy/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-cherrypy/Makefile')
-rw-r--r--www/py-cherrypy/Makefile28
1 files changed, 14 insertions, 14 deletions
diff --git a/www/py-cherrypy/Makefile b/www/py-cherrypy/Makefile
index 4e22322cd641..82a703f23885 100644
--- a/www/py-cherrypy/Makefile
+++ b/www/py-cherrypy/Makefile
@@ -6,31 +6,31 @@
#
PORTNAME= cherrypy
-PORTVERSION= 3.0.3
+PORTVERSION= 3.1.1
CATEGORIES= www python
MASTER_SITES= http://download.cherrypy.org/cherrypy/${PORTVERSION}/ \
http://nivi.interfree.it/distfiles/${PORTNAME}/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
-DISTNAME= CherryPy-${PORTVERSION:C/\.b$/beta/}
+DISTNAME= CherryPy-${PORTVERSION}
MAINTAINER= nivit@FreeBSD.org
COMMENT= A pythonic, object-oriented web development framework
-USE_PYTHON= 2.3+
-USE_PYDISTUTILS= yes
-PYDISTUTILS_PKGNAME= CherryPy
+.if !defined(NOPORTEXAMPLES)
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}cheetah>=2.0.1:${PORTSDIR}/devel/py-cheetah
-REINPLACE_ARGS= -i.bak -e 's,%%DOCSDIR%%,${DOCSDIR},'
-
-.if defined(NOPORTEXAMPLES)
-MAKE_ENV+= NOPORTEXAMPLES=${NOPORTEXAMPLES}
+EXAMPLESDIR= ${PREFIX}/share/examples/${PKGNAMEPREFIX}${PORTNAME}
.endif
-.if defined(NOPORTDOCS)
-MAKE_ENV+= NOPORTDOCS=${NOPORTDOCS}
-.endif
+USE_PYTHON= 2.4+
+USE_PYDISTUTILS= yes
+PYDISTUTILS_PKGNAME= CherryPy
-post-patch:
- @${REINPLACE_CMD} ${WRKSRC}/${PYSETUP}
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ cd ${PYTHONPREFIX_SITELIBDIR}/cherrypy && ${COPYTREE_SHARE} tutorial ${EXAMPLESDIR}
+.endif
+ ${RM} -R ${PYTHONPREFIX_SITELIBDIR}/cherrypy/tutorial
.include <bsd.port.mk>