aboutsummaryrefslogtreecommitdiffstats
path: root/www/py-plone.app.content/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/py-plone.app.content/Makefile')
-rw-r--r--www/py-plone.app.content/Makefile42
1 files changed, 42 insertions, 0 deletions
diff --git a/www/py-plone.app.content/Makefile b/www/py-plone.app.content/Makefile
new file mode 100644
index 000000000000..9ceda32cdabd
--- /dev/null
+++ b/www/py-plone.app.content/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: py-plone.app.content
+# Date created: 03 January 2012
+# Whom: Ruslan Mahmatkhanov <cvs-src@yandex.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= plone.app.content
+PORTVERSION= 2.0.7
+CATEGORIES= www python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= rm@FreeBSD.org
+COMMENT= Content Views for Plone
+
+LICENSE= GPLv2
+
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}plone.memoize>=0:${PORTSDIR}/www/py-plone.memoize \
+ ${PYTHON_PKGNAMEPREFIX}plone.i18n>=0:${PORTSDIR}/www/py-plone.i18n \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18n>=0:${PORTSDIR}/devel/py-zope.i18n \
+ ${PYTHON_PKGNAMEPREFIX}zope.i18nmessageid>=0:${PORTSDIR}/textproc/py-zope.i18nmessageid \
+ ${PYTHON_PKGNAMEPREFIX}zope.interface>=0:${PORTSDIR}/devel/py-zope.interface \
+ ${PYTHON_PKGNAMEPREFIX}zope.component>=0:${PORTSDIR}/devel/py-zope.component \
+ ${PYTHON_PKGNAMEPREFIX}zope.container>=0:${PORTSDIR}/devel/py-zope.container \
+ ${PYTHON_PKGNAMEPREFIX}zope.event>=0:${PORTSDIR}/devel/py-zope.event \
+ ${PYTHON_PKGNAMEPREFIX}zope.lifecycleevent>=0:${PORTSDIR}/devel/py-zope.lifecycleevent \
+ ${PYTHON_PKGNAMEPREFIX}zope.publisher>=0:${PORTSDIR}/devel/py-zope.publisher \
+ ${PYTHON_PKGNAMEPREFIX}zope.schema>=0:${PORTSDIR}/devel/py-zope.schema \
+ ${PYTHON_PKGNAMEPREFIX}zope.viewlet>=0:${PORTSDIR}/devel/py-zope.viewlet \
+ ${PYTHON_PKGNAMEPREFIX}Acquisition>=0:${PORTSDIR}/devel/py-Acquisition \
+ ${PYTHON_PKGNAMEPREFIX}Products.ATContentTypes>=0:${PORTSDIR}/devel/py-Products.ATContentTypes \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFCore>=2.2.0:${PORTSDIR}/devel/py-Products.CMFCore \
+ ${PYTHON_PKGNAMEPREFIX}Products.CMFDefault>=0:${PORTSDIR}/devel/py-Products.CMFDefault
+
+DIST_SUBDIR= zope
+USE_PYTHON= yes
+USE_PYDISTUTILS= easy_install
+USE_ZIP= yes
+#USE_ZOPE= yes
+
+.include <bsd.port.mk>