aboutsummaryrefslogtreecommitdiffstats
path: root/www/seamonkey/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/seamonkey/Makefile')
-rw-r--r--www/seamonkey/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/www/seamonkey/Makefile b/www/seamonkey/Makefile
index d5555c8120cb..c309c93d1015 100644
--- a/www/seamonkey/Makefile
+++ b/www/seamonkey/Makefile
@@ -239,6 +239,12 @@ post-patch:
${WRKSRC}/build/unix/$${pcfile}.pc.in; \
done
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^bind[0-9]*-base-[0-9]'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: bind installed with PORT_REPLACES_BASE_BIND causes build problems."; \
+ ${FALSE}; \
+ fi
+
post-build:
${SED} -e "s|%%PREFIX%%|${PREFIX}|g" -e "s|%%MOZILLA%%|${MOZILLA}|g" \
${FILESDIR}/mozilla.sh >${WRKSRC}/${MOZILLA}