aboutsummaryrefslogtreecommitdiffstats
path: root/www/serf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/serf/Makefile')
-rw-r--r--www/serf/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/www/serf/Makefile b/www/serf/Makefile
new file mode 100644
index 000000000000..af58e6c82d13
--- /dev/null
+++ b/www/serf/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: apr
+# Date created: 28 May 2008
+# Whom: Craig Rodrigues <rodrigc@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= serf
+PORTVERSION= 0.1.2
+CATEGORIES= www
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE} \
+ ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= db
+
+MAINTAINER= rodrigc@FreeBSD.org
+COMMENT= Serf HTTP client library
+
+LIB_DEPENDS+= apr:${PORTSDIR}/devel/apr
+
+PROJECTHOST= serf
+PORTDOCS= design-guide.txt
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+CONFIGURE_ARGS+= --with-apr=${PREFIX}/bin/apr-1-config \
+ --with-apr-util=${PREFIX}/bin/apu-1-config
+
+post-install:
+ ${MKDIR} ${DOCSDIR}
+.if !defined(NOPORTDOCS)
+ ${INSTALL_DATA} ${WRKSRC}/design-guide.txt ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>