aboutsummaryrefslogtreecommitdiffstats
path: root/www/typo3-lts/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'www/typo3-lts/Makefile')
-rw-r--r--www/typo3-lts/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/www/typo3-lts/Makefile b/www/typo3-lts/Makefile
index 5ac6d8f148c8..204130a68151 100644
--- a/www/typo3-lts/Makefile
+++ b/www/typo3-lts/Makefile
@@ -63,28 +63,26 @@ do-install:
post-install:
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*" | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@(root,wheel,) #p' >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) -path "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*" | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner root\n@group wheel" >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@(${WWWOWN},${WWWGRP},) #p' >> ${TMPPLIST}
@cd ${STAGEDIR}${PREFIX}; \
${FIND} * \( -type f -or -type l \) \
-not \( -path "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*" -or \
-path "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*" \) | \
- ${SORT} >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} -d * -type d -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner ${WWWOWN}\n@group ${WWWGRP}" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} -d * -type d -regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
- @${ECHO_CMD} -e "@owner root\n@group wheel" >> ${TMPPLIST}
- @cd ${STAGEDIR}${PREFIX}; ${FIND} * -type d \
+ ${SORT} | ${SED} -ne 's#^#@(root,wheel,) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} -d * -type d -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" | \
+ ${SORT} | ${SED} -ne 's#^#@dir(root,wheel,) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} -d * -type d -regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" | \
+ ${SORT} | ${SED} -ne 's#^#@dir(${WWWOWN},${WWWGRP},) #p' >> ${TMPPLIST}
+ @cd ${STAGEDIR}${PREFIX}; \
+ ${FIND} * -type d \
-path "${TYPO3WWW}/*" \
-not \( -regex "${TYPO3WWW}/${PORTNAME}-${TYPO3RELEASE}/*.*" -or \
-regex "${TYPO3WWW}/${TYPO3SRC}/typo3/ext/*.*" \) | \
- ${SORT} | ${SED} -ne 's#^#@dirrmtry #p' >> ${TMPPLIST}
+ ${SORT} | ${SED} -ne 's#^#@dir(root,wheel,) #p' >> ${TMPPLIST}
.include <bsd.port.mk>