aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Continuity/Makefile31
-rw-r--r--www/p5-Continuity/distinfo3
-rw-r--r--www/p5-Continuity/pkg-descr7
-rw-r--r--www/p5-Continuity/pkg-plist11
5 files changed, 53 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 3d6ea799b074..18d5f2f5207e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -741,6 +741,7 @@
SUBDIR += p5-Class-DBI-FromForm
SUBDIR += p5-ClearSilver
SUBDIR += p5-Compress-LeadingBlankSpaces
+ SUBDIR += p5-Continuity
SUBDIR += p5-Cookie-XS
SUBDIR += p5-DBIx-Class-HTMLWidget
SUBDIR += p5-Data-TreeDumper-Renderer-DHTML
diff --git a/www/p5-Continuity/Makefile b/www/p5-Continuity/Makefile
new file mode 100644
index 000000000000..3181de75af46
--- /dev/null
+++ b/www/p5-Continuity/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: www/p5-Continuity
+# Date created: 07 July 2008
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Continuity
+PORTVERSION= 0.994
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../by-authors/id/A/AW/AWWAIID
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Stateful Web applications in Perl
+
+BUILD_DEPENDS= p5-Event>0:${PORTSDIR}/devel/p5-Event \
+ p5-Coro>=4.37:${PORTSDIR}/devel/p5-Coro \
+ p5-libwww>0:${PORTSDIR}/www/p5-libwww
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= 5.8.0+
+
+MAN3= Continuity.3 \
+ Continuity::Adapt::FCGI.3 \
+ Continuity::Adapt::HttpDaemon.3 \
+ Continuity::Mapper.3 \
+ Continuity::Request.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Continuity/distinfo b/www/p5-Continuity/distinfo
new file mode 100644
index 000000000000..78477959b4ee
--- /dev/null
+++ b/www/p5-Continuity/distinfo
@@ -0,0 +1,3 @@
+MD5 (Continuity-0.994.tar.gz) = d236e23e78f0fc45e9c1de8fdd914485
+SHA256 (Continuity-0.994.tar.gz) = e46c5559f22b58e1f232dba3bad5938cea8142e920cf3b17c783994c5fdcc37a
+SIZE (Continuity-0.994.tar.gz) = 73290
diff --git a/www/p5-Continuity/pkg-descr b/www/p5-Continuity/pkg-descr
new file mode 100644
index 000000000000..1f98783fcb3c
--- /dev/null
+++ b/www/p5-Continuity/pkg-descr
@@ -0,0 +1,7 @@
+Continuity is a library to simplify web applications. Each session is
+written and runs as a persistant application, and is able to request
+additional input at any time without exiting. This is significantly
+different from the traditional CGI model of web applications in which a
+program is restarted for each new request.
+
+WWW: http://search.cpan.org/dist/Continuity/
diff --git a/www/p5-Continuity/pkg-plist b/www/p5-Continuity/pkg-plist
new file mode 100644
index 000000000000..b1f2f231a6c2
--- /dev/null
+++ b/www/p5-Continuity/pkg-plist
@@ -0,0 +1,11 @@
+%%SITE_PERL%%/Continuity.pm
+%%SITE_PERL%%/Continuity/Adapt/FCGI.pm
+%%SITE_PERL%%/Continuity/Adapt/HttpDaemon.pm
+%%SITE_PERL%%/Continuity/Inspector.pm
+%%SITE_PERL%%/Continuity/Mapper.pm
+%%SITE_PERL%%/Continuity/Request.pm
+%%SITE_PERL%%/Continuity/RequestHolder.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Continuity/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Continuity
+@dirrmtry %%SITE_PERL%%/Continuity/Adapt
+@dirrmtry %%SITE_PERL%%/Continuity