aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/autoindex2/Makefile10
-rw-r--r--www/autoindex2/pkg-plist13
2 files changed, 7 insertions, 16 deletions
diff --git a/www/autoindex2/Makefile b/www/autoindex2/Makefile
index 79edc7a09052..01295171945e 100644
--- a/www/autoindex2/Makefile
+++ b/www/autoindex2/Makefile
@@ -14,7 +14,7 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
USES= dos2unix
USE_PHP= session
-DEFAULT_VERSIONS= php=5
+DEFAULT_VERSIONS+= php=5
CONFLICTS= AutoIndex-1*
LATEST_LINK= AutoIndex2
NO_BUILD= yes
@@ -23,10 +23,12 @@ INSTALLDIR?= ${WWWDIR}
PLIST_SUB= WWWOWN=${WWWOWN} WWWGRP=${WWWGRP} \
INSTALLDIR=${INSTALLDIR:S,^${PREFIX}/,,}
+post-extract:
+ ${MV} ${WRKSRC}/config.php ${WRKSRC}/config.php.sample
+ ${MV} ${WRKSRC}/.htpasswd.autoindex ${WRKSRC}/.htpasswd.autoindex.sample
+
do-install:
@${MKDIR} ${STAGEDIR}${INSTALLDIR}
- cd ${WRKSRC} && ${MV} config.php config.php.sample
- cd ${WRKSRC} && ${MV} .htpasswd.autoindex .htpasswd.autoindex.sample
- cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${INSTALLDIR}
+ (cd ${WRKSRC} && ${COPYTREE_SHARE} . ${STAGEDIR}${INSTALLDIR})
.include <bsd.port.mk>
diff --git a/www/autoindex2/pkg-plist b/www/autoindex2/pkg-plist
index 90493fc43168..ee3908a5a784 100644
--- a/www/autoindex2/pkg-plist
+++ b/www/autoindex2/pkg-plist
@@ -230,16 +230,5 @@
%%INSTALLDIR%%/templates/readme.html
@owner
@group
-@dirrm %%INSTALLDIR%%/classes
-@dirrm %%INSTALLDIR%%/index_icons/apache
-@dirrm %%INSTALLDIR%%/index_icons/kde
-@dirrm %%INSTALLDIR%%/index_icons/osx
-@dirrm %%INSTALLDIR%%/index_icons/winvista
-@dirrm %%INSTALLDIR%%/index_icons/winxp
-@dirrm %%INSTALLDIR%%/index_icons
-@dirrm %%INSTALLDIR%%/languages
-@dirrm %%INSTALLDIR%%/templates/default
-@dirrm %%INSTALLDIR%%/templates/simple_image_gallery
-@dirrm %%INSTALLDIR%%/templates
-@dirrmtry %%INSTALLDIR%%
+@dir %%INSTALLDIR%%