aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/resin3/Makefile5
-rw-r--r--www/resin3/files/patch-configure28
2 files changed, 27 insertions, 6 deletions
diff --git a/www/resin3/Makefile b/www/resin3/Makefile
index 31f1e4470218..4182be29cb33 100644
--- a/www/resin3/Makefile
+++ b/www/resin3/Makefile
@@ -18,6 +18,7 @@ JAVA_VERSION= 1.2+
HAS_CONFIGURE= yes
USE_PYTHON= yes
USE_REINPLACE= yes
+USE_OPENSSL= yes
# Customizable settings
RUNASUSER?= www
@@ -55,7 +56,9 @@ COPYDIRS= lib libexec webapps
.include <bsd.port.pre.mk>
# Pass JAVA_HOME as determined by bsd.java.mk
-CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME}
+CONFIGURE_ARGS+= --with-java-home=${JAVA_HOME} \
+ --with-openssl-lib=${OPENSSLLIB} \
+ --with-openssl-include=${OPENSSLINC}
# Install the Apache plugin if needed
.if defined(WITH_APACHE) && (${WITH_APACHE} == yes || ${WITH_APACHE} == YES)
diff --git a/www/resin3/files/patch-configure b/www/resin3/files/patch-configure
index 67ad30e33399..266d490f8a4c 100644
--- a/www/resin3/files/patch-configure
+++ b/www/resin3/files/patch-configure
@@ -1,8 +1,6 @@
-$FreeBSD$
-
---- configure.orig Tue Oct 12 18:34:32 2004
-+++ configure Tue Oct 12 18:34:48 2004
-@@ -8487,20 +8487,6 @@
+--- configure.orig Wed Jan 12 00:00:26 2005
++++ configure Mon Apr 25 11:21:46 2005
+@@ -8669,20 +8669,6 @@
# Using Perl if it's available.
#
PERL=`which perl`
@@ -23,3 +21,23 @@ $FreeBSD$
#if test -z "${LD_SHLIB}"; then
# AC_MSG_ERROR([Can't determine compilation flags.]);
+@@ -8947,8 +8933,8 @@
+
+ if test -z "${OPENSSL_LIB}"; then
+ foo=bar
+-elif test -r "${OPENSSL_LIB}/libcrypt.so"; then
+- SSL_LIBS="${SSL_LIBS} -lcrypt"
++elif test -r "${OPENSSL_LIB}/libcrypto.so"; then
++ SSL_LIBS="${SSL_LIBS} -lcrypto"
+ elif test -r "${OPENSSL_LIB}/libcrypt.dylib"; then
+ SSL_LIBS="${SSL_LIBS} -lcrypt"
+ elif test -r "${OPENSSL_LIB}/libcrypt.a"; then
+@@ -8983,7 +8969,7 @@
+ foo=bar
+ elif test -z "${OPENSSL_LIB}"; then
+ foo=bar
+-elif test ! -r "${OPENSSL_LIB}/libcrypt.so" -a \
++elif test ! -r "${OPENSSL_LIB}/libcrypto.so" -a \
+ ! -r "${OPENSSL_LIB}/libcrypt.dylib" -a \
+ ! -r "${OPENSSL_LIB}/libcrypt.a" ; then
+ { { echo "$as_me:$LINENO: error: Can't find valid OpenSSL library in ${OPENSSL_LIB}" >&5