aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/nghttp2/Makefile2
-rw-r--r--www/nghttp2/distinfo4
-rw-r--r--www/nghttp2/files/patch-src-asio_common.cc14
-rw-r--r--www/nghttp2/pkg-plist2
4 files changed, 18 insertions, 4 deletions
diff --git a/www/nghttp2/Makefile b/www/nghttp2/Makefile
index b0187545805f..f991a2239bc4 100644
--- a/www/nghttp2/Makefile
+++ b/www/nghttp2/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= nghttp2
-PORTVERSION= 1.4.0
+PORTVERSION= 1.5.0
CATEGORIES= www net
MASTER_SITES= https://github.com/tatsuhiro-t/${PORTNAME}/releases/download/v${PORTVERSION}/ \
LOCAL/sunpoet
diff --git a/www/nghttp2/distinfo b/www/nghttp2/distinfo
index 01cd6a1ee7b3..910417391966 100644
--- a/www/nghttp2/distinfo
+++ b/www/nghttp2/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nghttp2-1.4.0.tar.xz) = 20d1481fe7fa65fd4f25457a43406a6f627a34f19b61f488a18ab56e2ef15b65
-SIZE (nghttp2-1.4.0.tar.xz) = 1388820
+SHA256 (nghttp2-1.5.0.tar.xz) = 52e345d46d6f990dc19be8a35403a5230345182d26d04cb82abbea4a168f5987
+SIZE (nghttp2-1.5.0.tar.xz) = 1398256
diff --git a/www/nghttp2/files/patch-src-asio_common.cc b/www/nghttp2/files/patch-src-asio_common.cc
new file mode 100644
index 000000000000..896d6f24bf3e
--- /dev/null
+++ b/www/nghttp2/files/patch-src-asio_common.cc
@@ -0,0 +1,14 @@
+--- src/asio_common.cc.orig 2015-11-26 13:27:10 UTC
++++ src/asio_common.cc
+@@ -177,9 +177,11 @@ bool tls_h2_negotiated(ssl_socket &socke
+ unsigned int next_proto_len = 0;
+
+ SSL_get0_next_proto_negotiated(ssl, &next_proto, &next_proto_len);
++#if OPENSSL_VERSION_NUMBER >= 0x10002000L
+ if (next_proto == nullptr) {
+ SSL_get0_alpn_selected(ssl, &next_proto, &next_proto_len);
+ }
++#endif // OPENSSL_VERSION_NUMBER >= 0x10002000L
+
+ if (next_proto == nullptr) {
+ return false;
diff --git a/www/nghttp2/pkg-plist b/www/nghttp2/pkg-plist
index db83cf97ae11..5fda820704c2 100644
--- a/www/nghttp2/pkg-plist
+++ b/www/nghttp2/pkg-plist
@@ -12,7 +12,7 @@ include/nghttp2/nghttp2ver.h
lib/libnghttp2.a
lib/libnghttp2.so
lib/libnghttp2.so.14
-lib/libnghttp2.so.14.2.0
+lib/libnghttp2.so.14.3.0
%%ASIO%%lib/libnghttp2_asio.a
%%ASIO%%lib/libnghttp2_asio.so
%%ASIO%%lib/libnghttp2_asio.so.1