aboutsummaryrefslogtreecommitdiffstats
path: root/www
diff options
context:
space:
mode:
Diffstat (limited to 'www')
-rw-r--r--www/firefox/Makefile2
-rw-r--r--www/firefox/files/patch-bug8243177
-rw-r--r--www/firefox/files/patch-toolkit-components-osfile-osfile_unix_allthreads.jsm11
3 files changed, 16 insertions, 4 deletions
diff --git a/www/firefox/Makefile b/www/firefox/Makefile
index 127dfa913e8d..951d1b6e8f93 100644
--- a/www/firefox/Makefile
+++ b/www/firefox/Makefile
@@ -3,7 +3,7 @@
PORTNAME= firefox
DISTVERSION= 21.0
-PORTREVISION= 1
+PORTREVISION= 2
PORTEPOCH= 1
CATEGORIES= www ipv6
MASTER_SITES= MOZILLA/${PORTNAME}/releases/${DISTVERSION}/source
diff --git a/www/firefox/files/patch-bug824317 b/www/firefox/files/patch-bug824317
index 71927d593caf..ebd8ad4e5946 100644
--- a/www/firefox/files/patch-bug824317
+++ b/www/firefox/files/patch-bug824317
@@ -2,13 +2,14 @@ diff --git a/xpcom/string/public/nsAlgorithm.h b/xpcom/string/public/nsAlgorithm
index fa50194a..c5f5737 100644
--- xpcom/string/public/nsAlgorithm.h
+++ xpcom/string/public/nsAlgorithm.h
-@@ -42,7 +42,10 @@ NS_MAX( const T& a, const T& b )
+@@ -42,7 +42,11 @@ NS_MAX( const T& a, const T& b )
return a > b ? a : b;
}
-
+
-#if defined(_MSC_VER) && (_MSC_VER < 1600)
+#if (defined(_MSC_VER) && (_MSC_VER < 1600)) || \
-+ ((defined(__GLIBCXX__) && __GLIBCXX__ < 20121005) && \
++ (((defined(__GNUC_MINOR__) && __GNUC_MINOR__ < 8) || \
++ (defined(__GLIBCXX__) && __GLIBCXX__ < 20121005)) && \
+ (defined(_GLIBCXX_USE_LONG_LONG) && \
+ (!_GLIBCXX_USE_C99 || _GLIBCXX_USE_C99_LONG_LONG_DYNAMIC)))
namespace std {
diff --git a/www/firefox/files/patch-toolkit-components-osfile-osfile_unix_allthreads.jsm b/www/firefox/files/patch-toolkit-components-osfile-osfile_unix_allthreads.jsm
new file mode 100644
index 000000000000..d8a3612e1702
--- /dev/null
+++ b/www/firefox/files/patch-toolkit-components-osfile-osfile_unix_allthreads.jsm
@@ -0,0 +1,11 @@
+--- toolkit/components/osfile/osfile_unix_allthreads.jsm.orig 2013-05-11 21:19:53.000000000 +0200
++++ toolkit/components/osfile/osfile_unix_allthreads.jsm 2013-06-02 17:15:05.000000000 +0200
+@@ -40,7 +40,7 @@ if (typeof Components != "undefined") {
+ // Open libc
+ let libc;
+ let libc_candidates = [ "libSystem.B.dylib",
+- "libc.so.6",
++ "libc.so.7",
+ "libc.so" ];
+ for (let i = 0; i < libc_candidates.length; ++i) {
+ try {