aboutsummaryrefslogtreecommitdiffstats
path: root/x11-fm/xdiskusage/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-fm/xdiskusage/Makefile')
-rw-r--r--x11-fm/xdiskusage/Makefile37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-fm/xdiskusage/Makefile b/x11-fm/xdiskusage/Makefile
new file mode 100644
index 000000000000..c1ace826a7f0
--- /dev/null
+++ b/x11-fm/xdiskusage/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: xdiskusage
+# Date created: 2000-09-23
+# Whom: Trevor Johnson <trevor@jpj.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xdiskusage
+PORTVERSION= 1.41
+CATEGORIES= x11-fm
+MASTER_SITES= http://xdiskusage.sourceforge.net/
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= trevor@FreeBSD.org
+
+LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_GMAKE= yes
+USE_MESA= yes
+USE_X_PREFIX= yes
+
+do-build:
+.for i in panels xdiskusage
+ ${CXX} ${CXXFLAGS} -I${X11BASE}/include -c ${WRKSRC}/${i}.C \
+ -o ${WRKSRC}/${i}.o
+.endfor
+ ${CXX} ${CXXFLAGS} -L${X11BASE}/lib -o ${WRKSRC}/xdiskusage \
+ ${WRKSRC}/panels.o ${WRKSRC}/xdiskusage.o -lfltk -lm -lMesaGL
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xdiskusage ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/xdiskusage
+ ${INSTALL_DATA} ${WRKSRC}/README ${PREFIX}/share/doc/xdiskusage
+.endif
+
+.include <bsd.port.mk>