aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/libgnomeui/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/libgnomeui/Makefile')
-rw-r--r--x11-toolkits/libgnomeui/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/x11-toolkits/libgnomeui/Makefile b/x11-toolkits/libgnomeui/Makefile
index 8e294ee5e465..df7a132312bd 100644
--- a/x11-toolkits/libgnomeui/Makefile
+++ b/x11-toolkits/libgnomeui/Makefile
@@ -3,14 +3,13 @@
# Whom: Joe Marcus Clarke <marcus@FreBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11-toolkits/libgnomeui/Makefile,v 1.66 2005/09/07 04:43:08 marcus Exp $
+# $MCom: ports/x11-toolkits/libgnomeui/Makefile,v 1.79 2006/04/13 07:52:43 bland Exp $
PORTNAME= libgnomeui
-PORTVERSION= 2.12.1
-PORTREVISION= 1
+PORTVERSION= 2.14.1
CATEGORIES= x11-toolkits gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -21,12 +20,13 @@ LIB_DEPENDS+= gnome-keyring.0:${PORTSDIR}/security/gnomekeyring \
RUN_DEPENDS= ${X11BASE}/share/icons/gnome/index.theme:${PORTSDIR}/misc/gnome-icon-theme
USE_BZIP2= yes
+USE_GETTEXT= yes
USE_X_PREFIX= yes
USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack gnomehier libbonoboui ltverhack
INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
USE_BISON= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"