aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits/pango/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits/pango/Makefile')
-rw-r--r--x11-toolkits/pango/Makefile20
1 files changed, 13 insertions, 7 deletions
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index fc19e07e2a9e..cc14f782d46a 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -1,10 +1,10 @@
# Created by: Maxim Sobolev <sobomax@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/trunk/x11-toolkits/pango/Makefile 19012 2014-03-08 07:21:34Z kwm $
+# $MCom: ports/trunk/x11-toolkits/pango/Makefile 19945 2014-10-15 05:41:04Z gusi $
PORTNAME= pango
-PORTVERSION= 1.34.1
-PORTREVISION?= 7
+PORTVERSION= 1.36.8
+PORTREVISION?= 0
CATEGORIES= x11-toolkits
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -16,22 +16,25 @@ USES= tar:xz
.if !defined(REFERENCE_PORT)
-BUILD_DEPENDS= fontconfig>=2.10.91:${PORTSDIR}/x11-fonts/fontconfig
+BUILD_DEPENDS= fontconfig>=2.10.91:${PORTSDIR}/x11-fonts/fontconfig \
+ cairo>=1.12.10,2:${PORTSDIR}/graphics/cairo
LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2 \
libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
RUN_DEPENDS= ${FONTSCALE}:${PORTSDIR}/x11-fonts/xorg-fonts-truetype \
${FONTENCOD}:${PORTSDIR}/x11-fonts/encodings
-USES+= gettext gmake libtool:keepla pathfix pkgconfig
+USES+= gettext gmake libtool pathfix pkgconfig
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-USE_GNOME= cairo glib20 gnomehier introspection:build referencehack
+USE_GNOME= cairo glib20 introspection:build referencehack
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-PLIST_SUB= VERSION="1.8.0"
+VERSION= 1.8.0
+LIBVERSION= 0.3600.8
+PLIST_SUB+= VERSION=${VERSION} LIBVERSION=${LIBVERSION}
FONTSCALE= ${LOCALBASE}/lib/X11/fonts/TTF/luximb.ttf
FONTENCOD= ${LOCALBASE}/lib/X11/fonts/encodings/encodings.dir
@@ -56,6 +59,9 @@ pre-configure:
@${FALSE}
.endif
+post-install:
+ @${MKDIR} ${STAGEDIR}${PREFIX}/etc/pango/
+
.include <bsd.port.mk>
.endif