aboutsummaryrefslogtreecommitdiffstats
path: root/x11-toolkits
diff options
context:
space:
mode:
Diffstat (limited to 'x11-toolkits')
-rw-r--r--x11-toolkits/qt33/Makefile10
1 files changed, 4 insertions, 6 deletions
diff --git a/x11-toolkits/qt33/Makefile b/x11-toolkits/qt33/Makefile
index 164c35d3a87b..4e39c0a16d2b 100644
--- a/x11-toolkits/qt33/Makefile
+++ b/x11-toolkits/qt33/Makefile
@@ -77,10 +77,6 @@ PACKAGE_COOKIE= ${WRKDIR}/.package_done.${PORTNAME}.${PREFIX:S/\//_/g}
.include <bsd.port.pre.mk>
-.if exists(${PREFIX})
-PREFIX_REAL!= /bin/realpath ${PREFIX}
-.endif
-
# The previous Qt port versions installed qmake and qmake's specs under LOCALBASE
# The new devel/qmake port installs them under LOCALBASE. We can use
# either one here, but we prefer the newer:
@@ -197,8 +193,10 @@ post-build:
@cd ${WRKSRC}/tools/${tool}; ${SETENV} ${MAKE_ENV} ${MAKE}
.endfor
@${RM} -f ${WRKSRC}/doc/html/qmake*
- ${REINPLACE_CMD} -e 's|${PREFIX_REAL}/include/q.*h||g' \
- -e 's|${PREFIX_REAL}/include/private/q.*h||g' \
+
+ PREFIX_REAL=$$(/bin/realpath ${PREFIX}); \
+ ${REINPLACE_CMD} -e "s|$${PREFIX_REAL}/include/q.*h||g" \
+ -e "s|$${PREFIX_REAL}/include/private/q.*h||g" \
${WRKSRC}/src/Makefile
# Work around qmake generated dependencies