aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/cwm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/cwm/Makefile')
-rw-r--r--x11-wm/cwm/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-wm/cwm/Makefile b/x11-wm/cwm/Makefile
new file mode 100644
index 000000000000..232cd2d3c415
--- /dev/null
+++ b/x11-wm/cwm/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= cwm
+PORTVERSION= 5.5
+CATEGORIES= x11-wm
+MASTER_SITES= http://chneukirchen.org/releases/ \
+ http://github.com/chneukirchen/${PORTNAME}/archive/v${PORTVERSION}.tar.gz?dummy=/
+
+MAINTAINER= braakvaak@aol.com
+COMMENT= Minimalistic window manager for X11 based on evilwm
+
+LICENSE= BSD2CLAUSE
+
+LIB_DEPENDS= libfontconfig.so:${PORTSDIR}/x11-fonts/fontconfig
+
+USES= pkgconfig:build
+USE_XORG= x11 xft xinerama xrandr
+
+PLIST_FILES= bin/cwm \
+ man/man1/cwm.1.gz \
+ man/man5/cwmrc.5.gz
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/cwm ${STAGEDIR}${PREFIX}/bin
+ @${INSTALL_MAN} ${WRKSRC}/cwm.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+ @${INSTALL_MAN} ${WRKSRC}/cwmrc.5 ${STAGEDIR}${MAN5PREFIX}/man/man5
+
+.include <bsd.port.mk>