aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/plank/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/plank/Makefile')
-rw-r--r--x11-wm/plank/Makefile24
1 files changed, 6 insertions, 18 deletions
diff --git a/x11-wm/plank/Makefile b/x11-wm/plank/Makefile
index e39c024fe945..9e3274ef40bd 100644
--- a/x11-wm/plank/Makefile
+++ b/x11-wm/plank/Makefile
@@ -22,6 +22,7 @@ GNU_CONFIGURE= yes
USE_GNOME= glib20 gtk30 gdkpixbuf2 libxml2 libwnck3
USE_XORG= x11
INSTALLS_ICONS= yes
+OPTIONS_SUB= yes
OPTIONS_DEFINE= NLS DBUSMENU
DBUSMENU_DESC= DBusMenu protocol
@@ -30,23 +31,10 @@ CONFIGURE_ARGS= --enable-gee-0.8 \
--disable-benchmark \
--disable-headless-tests
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-CONFIGURE_ARGS+=--enable-nls
-PLIST_SUB+= NLS=""
-.else
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDBUSMENU}
-# Need GTK3 support
-LIB_DEPENDS+= libdbusmenu-gtk3.so:${PORTSDIR}/devel/libdbusmenu
-CONFIGURE_ARGS+=--enable-dbusmenu
-.else
-CONFIGURE_ARGS+=--disable-dbusmenu
-.endif
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+DBUSMENU_LIB_DEPENDS= libdbusmenu-gtk3.so:${PORTSDIR}/devel/libdbusmenu
+DBUSMENU_CONFIGURE_ENABLE= dbusmenu
.include <bsd.port.mk>