aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/transset-df/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/transset-df/Makefile')
-rw-r--r--x11-wm/transset-df/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-wm/transset-df/Makefile b/x11-wm/transset-df/Makefile
new file mode 100644
index 000000000000..c2c93059bbb8
--- /dev/null
+++ b/x11-wm/transset-df/Makefile
@@ -0,0 +1,31 @@
+# Ports collection makefile for: transset-df
+# Date created: 2005-09-21
+# Whom: Andreas Kohn <andreas@syndrom23.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= transset-df
+PORTVERSION= 4
+CATEGORIES= x11-wm
+MASTER_SITES= http://forchheimer.se/transset-df/
+
+MAINTAINER= andreas@syndrom23.de
+COMMENT= Make your windows transparent
+
+USE_X_PREFIX= yes
+ALL_TARGET= transset-df
+MAKE_ARGS= CFLAGS="${CFLAGS}"
+
+PLIST_FILES= bin/transset-df
+
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} != xorg
+IGNORE= requires X.Org; install x11/xorg and try again
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/transset-df ${PREFIX}/bin
+
+.include <bsd.port.post.mk>