aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm/xfce4-desktop/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/xfce4-desktop/Makefile')
-rw-r--r--x11-wm/xfce4-desktop/Makefile30
1 files changed, 17 insertions, 13 deletions
diff --git a/x11-wm/xfce4-desktop/Makefile b/x11-wm/xfce4-desktop/Makefile
index 84b2c2430a94..112070e04868 100644
--- a/x11-wm/xfce4-desktop/Makefile
+++ b/x11-wm/xfce4-desktop/Makefile
@@ -20,26 +20,30 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-USES= gettext-tools gmake pkgconfig tar:bzip2 xfce
-GNU_CONFIGURE= yes
-INSTALLS_ICONS= yes
-USE_GNOME= glib20 gtk20 intltool libwnck cairo
+USES= gettext-tools gmake gnome pkgconfig tar:bzip2 xfce
+USE_GNOME= cairo glib20 gtk20 intltool libwnck
USE_XFCE= garcon libexo
USE_XORG= ice sm x11
+
+GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
INSTALL_TARGET= install-strip
-CONFIGURE_ARGS+=--enable-gio-unix \
+CONFIGURE_ARGS= --enable-gio-unix \
--enable-notifications
-OPTIONS_DEFINE= NLS THUNAR
-OPTIONS_DEFAULT= THUNAR
-NLS_USES= gettext-runtime
-NLS_CONFIGURE_ENABLE= nls
-THUNAR_USE= xfce=thunar
+OPTIONS_DEFINE= NLS THUNAR
+OPTIONS_DEFAULT= THUNAR
+OPTIONS_SUB= yes
+
+THUNAR_DESC= Thunar file manager support
+
+NLS_CONFIGURE_ENABLE= nls
+NLS_USES= gettext-runtime
+
THUNAR_CONFIGURE_ENABLE= thunarx
-THUNAR_CONFIGURE_WITH= file-manager-fallback=Thunar
-THUNAR_DESC= Thunar file manager support
-OPTIONS_SUB= yes
+THUNAR_CONFIGURE_WITH= file-manager-fallback=Thunar
+THUNAR_USE= xfce=thunar
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's|po ||' ${WRKSRC}/Makefile.in