aboutsummaryrefslogtreecommitdiffstats
path: root/x11-wm
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/fbdesk/Makefile11
1 files changed, 10 insertions, 1 deletions
diff --git a/x11-wm/fbdesk/Makefile b/x11-wm/fbdesk/Makefile
index 6986ecc8f91b..4a767988d4e9 100644
--- a/x11-wm/fbdesk/Makefile
+++ b/x11-wm/fbdesk/Makefile
@@ -17,4 +17,13 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_X_PREFIX= yes
GNU_CONFIGURE= yes
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 500000
+USE_REINPLACE= yes
+post-patch:
+ ${REINPLACE_CMD} -e "s/inttypes\.h/stdint\.h/" \
+ ${WRKSRC}/src/FbTk/Timer.hh
+.endif
+
+.include <bsd.port.post.mk>