aboutsummaryrefslogtreecommitdiffstats
path: root/x11/fluxbg/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/fluxbg/Makefile')
-rw-r--r--x11/fluxbg/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11/fluxbg/Makefile b/x11/fluxbg/Makefile
new file mode 100644
index 000000000000..bbf7aad1cfff
--- /dev/null
+++ b/x11/fluxbg/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: fluxbg
+# Date created: 30 September 2003
+# Whom: Adam Weinberger <adamw@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fluxbg
+PORTVERSION= 0.6
+CATEGORIES= x11
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= ports@FreeBSD.org
+COMMENT= Background changer for fluxbox/blackbox
+
+LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+USE_X_PREFIX= yes
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gnometarget
+
+post-patch:
+ @${REINPLACE_CMD} -e "s|%%X11BASE%%|${X11BASE}|g" \
+ ${WRKSRC}/src/fluxbg_conf.cc
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>