aboutsummaryrefslogtreecommitdiffstats
path: root/x11/gnome2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/gnome2/Makefile')
-rw-r--r--x11/gnome2/Makefile39
1 files changed, 20 insertions, 19 deletions
diff --git a/x11/gnome2/Makefile b/x11/gnome2/Makefile
index e03957c7112d..f2f5a96a6d29 100644
--- a/x11/gnome2/Makefile
+++ b/x11/gnome2/Makefile
@@ -3,12 +3,12 @@
# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/x11/gnome2/Makefile,v 1.236 2008/03/15 18:40:17 marcus Exp $
+# $MCom: ports/x11/gnome2/Makefile,v 1.260 2008/11/27 02:18:33 marcus Exp $
#
PORTNAME= gnome2
-PORTVERSION= 2.22.3
-PORTREVISION?= 1
+PORTVERSION= 2.24.2
+PORTREVISION?= 0
CATEGORIES?= x11 gnome
MASTER_SITES= # empty
DISTFILES= # empty
@@ -18,7 +18,7 @@ MAINTAINER= gnome@FreeBSD.org
COMMENT?= The "meta-port" for the GNOME 2 integrated X11 desktop
RUN_DEPENDS?= ${LOCALBASE}/libexec/gweather-applet-2:${PORTSDIR}/x11/gnome-applets \
- gnome-cd:${PORTSDIR}/audio/gnome-media \
+ gnome-audio-profiles-properties:${PORTSDIR}/audio/gnome-media \
gnome-dictionary:${PORTSDIR}/deskutils/gnome-utils \
eog:${PORTSDIR}/graphics/eog \
gconf-editor:${PORTSDIR}/sysutils/gconf-editor \
@@ -38,27 +38,20 @@ RUN_DEPENDS?= ${LOCALBASE}/libexec/gweather-applet-2:${PORTSDIR}/x11/gnome-apple
gok:${PORTSDIR}/accessibility/gok \
nautilus-cd-burner:${PORTSDIR}/sysutils/nautilus-cd-burner \
gcalctool:${PORTSDIR}/math/gcalctool \
- gucharmap:${PORTSDIR}/deskutils/gucharmap \
- zenity:${PORTSDIR}/x11/zenity \
${LOCALBASE}/lib/X11/fonts/bitstream-vera/Vera.ttf:${PORTSDIR}/x11-fonts/bitstream-vera \
${LOCALBASE}/libexec/gnome-netstatus-applet:${PORTSDIR}/net/gnome-netstatus \
dasher:${PORTSDIR}/accessibility/dasher \
evolution:${PORTSDIR}/mail/evolution \
${LOCALBASE}/libexec/evolution-webcal:${PORTSDIR}/www/evolution-webcal \
network-admin:${PORTSDIR}/sysutils/gnome-system-tools \
- gnome-nettool:${PORTSDIR}/net/gnome-nettool \
- vino-session:${PORTSDIR}/net/vino \
- exchange-connector-setup-2.22:${PORTSDIR}/mail/evolution-exchange \
+ vino-passwd:${PORTSDIR}/net/vino \
+ exchange-connector-setup-2.24:${PORTSDIR}/mail/evolution-exchange \
${LOCALBASE}/lib/gstreamer-0.10/.gstreamer-plugins-core.keep:${PORTSDIR}/multimedia/gstreamer-plugins-core \
${LOCALBASE}/lib/gstreamer-0.10/libgstgconfelements.so:${PORTSDIR}/devel/gstreamer-plugins-gconf \
totem:${PORTSDIR}/multimedia/totem \
gnome-control-center:${PORTSDIR}/sysutils/gnome-control-center \
- ${LOCALBASE}/share/gnome-background-properties/gnome-branded.xml:${PORTSDIR}/x11-themes/gnome-backgrounds \
- sound-juicer:${PORTSDIR}/audio/sound-juicer \
- ${LOCALBASE}/libdata/pkgconfig/libgtkhtml-2.0.pc:${PORTSDIR}/www/libgtkhtml \
+ ${LOCALBASE}/share/gnome-background-properties/gnome-nature.xml:${PORTSDIR}/x11-themes/gnome-backgrounds \
evince:${PORTSDIR}/graphics/evince \
- ${LOCALBASE}/libexec/fast-user-switch-applet:${PORTSDIR}/x11/fast-user-switch-applet \
- ${LOCALBASE}/lib/deskbar-applet/deskbar-applet:${PORTSDIR}/deskutils/deskbar-applet \
alacarte:${PORTSDIR}/deskutils/alacarte \
gnome-power-manager:${PORTSDIR}/sysutils/gnome-power-manager \
${LOCALBASE}/libexec/gnome-volume-manager:${PORTSDIR}/sysutils/gnome-volume-manager \
@@ -66,11 +59,9 @@ RUN_DEPENDS?= ${LOCALBASE}/libexec/gweather-applet-2:${PORTSDIR}/x11/gnome-apple
gnome-mount:${PORTSDIR}/sysutils/gnome-mount \
${LOCALBASE}/libexec/notification-daemon:${PORTSDIR}/deskutils/notification-daemon \
seahorse:${PORTSDIR}/security/seahorse \
- swfdec-player:${PORTSDIR}/multimedia/swfdec-gnome \
mousetweaks:${PORTSDIR}/accessibility/mousetweaks \
- vinagre:${PORTSDIR}/net/vinagre \
- cheese:${PORTSDIR}/multimedia/cheese \
- ${LOCALBASE}/share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi:${PORTSDIR}/sysutils/hal-info
+ ${LOCALBASE}/share/hal/fdi/information/10freedesktop/10-camera-ptp.fdi:${PORTSDIR}/sysutils/hal-info \
+ ${LOCALBASE}/share/sounds/freedesktop/index.theme:${PORTSDIR}/audio/freedesktop-sound-theme
NO_BUILD= yes
@@ -92,8 +83,18 @@ RUN_DEPENDS+= yelp:${PORTSDIR}/x11/yelp \
epiphany:${PORTSDIR}/www/epiphany
.endif
.if ${.CURDIR:T}!="gnome2-lite"
+RUN_DEPENDS+= empathy:${PORTSDIR}/net-im/empathy \
+ cheese:${PORTSDIR}/multimedia/cheese \
+ gucharmap:${PORTSDIR}/deskutils/gucharmap \
+ sound-juicer:${PORTSDIR}/audio/sound-juicer \
+ zenity:${PORTSDIR}/x11/zenity \
+ gnome-nettool:${PORTSDIR}/net/gnome-nettool \
+ swfdec-player:${PORTSDIR}/multimedia/swfdec-gnome \
+ vinagre:${PORTSDIR}/net/vinagre \
+ ${LOCALBASE}/lib/deskbar-applet/deskbar-applet:${PORTSDIR}/deskutils/deskbar-applet \
+ ${LOCALBASE}/lib/hamster-applet/hamster-applet:${PORTSDIR}/deskutils/hamster-applet
.if ${ARCH} == "i386"
-RUN_DEPENDS+= tomboy:${PORTSDIR}/deskutils/tomboy
+#RUN_DEPENDS+= tomboy:${PORTSDIR}/deskutils/tomboy
.endif
.if ${OSVERSION}>=600000
RUN_DEPENDS+= ekiga:${PORTSDIR}/net/ekiga