aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libgnome
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libgnome')
-rw-r--r--x11/libgnome/Makefile12
-rw-r--r--x11/libgnome/distinfo6
-rw-r--r--x11/libgnome/files/patch-ag4
-rw-r--r--x11/libgnome/files/patch-libgnome_gnome-program.c25
-rw-r--r--x11/libgnome/files/pkg-deinstall.in2
-rw-r--r--x11/libgnome/pkg-plist8
6 files changed, 23 insertions, 34 deletions
diff --git a/x11/libgnome/Makefile b/x11/libgnome/Makefile
index 5804300133cd..8356bc83aa48 100644
--- a/x11/libgnome/Makefile
+++ b/x11/libgnome/Makefile
@@ -3,15 +3,14 @@
# Whom: Yukihiro Nakai <Nakai@technologist.com>
#
# $FreeBSD$
-# $MCom: ports/x11/libgnome/Makefile,v 1.61 2005/09/07 16:21:36 marcus Exp $
+# $MCom: ports/x11/libgnome/Makefile,v 1.78 2006/04/13 07:52:41 bland Exp $
#
PORTNAME= libgnome
-PORTVERSION= 2.12.0.1
-PORTREVISION= 1
+PORTVERSION= 2.14.1
CATEGORIES= x11 gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.12
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:C/^([0-9]+\.[0-9]+).*/\1/}
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -20,16 +19,16 @@ COMMENT= Libraries for GNOME, a GNU desktop environment
BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
RUN_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+USE_GETTEXT= yes
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_REINPLACE= yes
USE_XPM= yes
USE_GMAKE= yes
USE_GNOME= gnomeprefix gnomehack intlhack esound \
gnomevfs2 libxslt ltverhack
USE_BISON= yes
INSTALLS_SHLIB= yes
-USE_AUTOTOOLS= libtool:15
+USE_AUTOTOOLS= libtool:15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
@@ -54,6 +53,7 @@ GCONF_SCHEMAS= desktop_gnome_accessibility_keyboard.schemas \
post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|' \
${WRKSRC}/libgnome/libgnome-2.0.pc.in
+ @${REINPLACE_CMD} -e '/^$$/d' ${WRKSRC}/po/POTFILES.in
.if defined(NOPORTDOCS)
@${REINPLACE_CMD} -e 's|gnome-data po doc|gnome-data po|g' \
${WRKSRC}/Makefile.in
diff --git a/x11/libgnome/distinfo b/x11/libgnome/distinfo
index 3405e21e69b3..42ba5385693f 100644
--- a/x11/libgnome/distinfo
+++ b/x11/libgnome/distinfo
@@ -1,3 +1,3 @@
-MD5 (gnome2/libgnome-2.12.0.1.tar.bz2) = f239a7ab132d2ec9039bb2537cca1e92
-SHA256 (gnome2/libgnome-2.12.0.1.tar.bz2) = f4cd8f6df545328b2b969d1fa8762d5398f7f6c517c7fac730f1d2196e4cf624
-SIZE (gnome2/libgnome-2.12.0.1.tar.bz2) = 955235
+MD5 (gnome2/libgnome-2.14.1.tar.bz2) = bf53815df10db62bbf00defd4100b8d8
+SHA256 (gnome2/libgnome-2.14.1.tar.bz2) = 4d091bd00e01392d65a856ca5b9fe648025c5988c844d58b25341a275b760fa7
+SIZE (gnome2/libgnome-2.14.1.tar.bz2) = 995007
diff --git a/x11/libgnome/files/patch-ag b/x11/libgnome/files/patch-ag
index 2caedc380d59..ceb23de357f2 100644
--- a/x11/libgnome/files/patch-ag
+++ b/x11/libgnome/files/patch-ag
@@ -1,7 +1,3 @@
-
-$FreeBSD$
- $MCom: ports/x11/libgnome/files/patch-ag,v 1.18 2005/07/04 00:15:01 marcus Exp $
-
--- libgnome/gnome-util.c 2002/03/19 17:16:21 1.1
+++ libgnome/gnome-util.c 2002/03/19 17:21:31
@@ -67,11 +67,11 @@
diff --git a/x11/libgnome/files/patch-libgnome_gnome-program.c b/x11/libgnome/files/patch-libgnome_gnome-program.c
index 9dd33f9c2838..70ecbfd8fce0 100644
--- a/x11/libgnome/files/patch-libgnome_gnome-program.c
+++ b/x11/libgnome/files/patch-libgnome_gnome-program.c
@@ -1,6 +1,6 @@
---- libgnome/gnome-program.c.orig Mon May 31 16:37:02 2004
-+++ libgnome/gnome-program.c Mon May 31 16:37:05 2004
-@@ -895,17 +895,17 @@
+--- libgnome/gnome-program.c.orig Tue Apr 4 06:55:12 2006
++++ libgnome/gnome-program.c Mon Apr 10 21:07:02 2006
+@@ -936,17 +936,17 @@ gnome_program_locate_file (GnomeProgram
attr_rel = "";
break;
case GNOME_FILE_DOMAIN_DATADIR:
@@ -21,7 +21,7 @@
attr_name = GNOME_PARAM_GNOME_DATADIR;
attr_rel = "/pixmaps";
break;
-@@ -917,7 +917,7 @@
+@@ -958,7 +958,7 @@ gnome_program_locate_file (GnomeProgram
case GNOME_FILE_DOMAIN_HELP:
prefix_rel = "/share/gnome/help";
attr_name = GNOME_PARAM_GNOME_DATADIR;
@@ -30,7 +30,7 @@
break;
case GNOME_FILE_DOMAIN_APP_LIBDIR:
prefix_rel = "/lib";
-@@ -926,19 +926,19 @@
+@@ -967,19 +967,19 @@ gnome_program_locate_file (GnomeProgram
search_path = FALSE;
break;
case GNOME_FILE_DOMAIN_APP_DATADIR:
@@ -53,18 +53,3 @@
attr_name = GNOME_PARAM_APP_DATADIR;
attr_rel = "/pixmaps";
search_path = FALSE;
-@@ -959,12 +959,12 @@
-
- attr_name = GNOME_PARAM_APP_DATADIR;
-
-- len = strlen ("/gnome/help/") +
-+ len = strlen ("/help/") +
- strlen (program->_priv->app_id) + 1;
- attr_rel = g_alloca (len);
- if (attr_rel == NULL /* bad things */)
- return NULL;
-- g_snprintf (attr_rel, len, "/gnome/help/%s", program->_priv->app_id);
-+ g_snprintf (attr_rel, len, "/help/%s", program->_priv->app_id);
-
- search_path = FALSE;
- break;
diff --git a/x11/libgnome/files/pkg-deinstall.in b/x11/libgnome/files/pkg-deinstall.in
index adb5cef39218..7377058cd835 100644
--- a/x11/libgnome/files/pkg-deinstall.in
+++ b/x11/libgnome/files/pkg-deinstall.in
@@ -1,7 +1,7 @@
#!/bin/sh
#
# $FreeBSD$
-# $MCom: ports/x11/libgnome/files/pkg-deinstall.in,v 1.2 2005/07/04 00:15:01 marcus Exp $
+# $MCom: ports/x11/libgnome/files/pkg-deinstall.in,v 1.4 2005/11/16 00:04:58 ahze Exp $
#
# Restore gconf keys of gnomevfs2.
diff --git a/x11/libgnome/pkg-plist b/x11/libgnome/pkg-plist
index 6f57b338254e..0b3acb8a4c1f 100644
--- a/x11/libgnome/pkg-plist
+++ b/x11/libgnome/pkg-plist
@@ -84,6 +84,7 @@ share/locale/is/LC_MESSAGES/libgnome-2.0.mo
share/locale/it/LC_MESSAGES/libgnome-2.0.mo
share/locale/ja/LC_MESSAGES/libgnome-2.0.mo
share/locale/ko/LC_MESSAGES/libgnome-2.0.mo
+share/locale/ku/LC_MESSAGES/libgnome-2.0.mo
share/locale/lt/LC_MESSAGES/libgnome-2.0.mo
share/locale/lv/LC_MESSAGES/libgnome-2.0.mo
share/locale/mk/LC_MESSAGES/libgnome-2.0.mo
@@ -95,6 +96,7 @@ share/locale/ne/LC_MESSAGES/libgnome-2.0.mo
share/locale/nl/LC_MESSAGES/libgnome-2.0.mo
share/locale/nn/LC_MESSAGES/libgnome-2.0.mo
share/locale/no/LC_MESSAGES/libgnome-2.0.mo
+share/locale/or/LC_MESSAGES/libgnome-2.0.mo
share/locale/pa/LC_MESSAGES/libgnome-2.0.mo
share/locale/pl/LC_MESSAGES/libgnome-2.0.mo
share/locale/pt/LC_MESSAGES/libgnome-2.0.mo
@@ -112,13 +114,19 @@ share/locale/sv/LC_MESSAGES/libgnome-2.0.mo
share/locale/ta/LC_MESSAGES/libgnome-2.0.mo
share/locale/th/LC_MESSAGES/libgnome-2.0.mo
share/locale/tr/LC_MESSAGES/libgnome-2.0.mo
+share/locale/tt/LC_MESSAGES/libgnome-2.0.mo
share/locale/uk/LC_MESSAGES/libgnome-2.0.mo
share/locale/vi/LC_MESSAGES/libgnome-2.0.mo
share/locale/wa/LC_MESSAGES/libgnome-2.0.mo
share/locale/xh/LC_MESSAGES/libgnome-2.0.mo
share/locale/yi/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_CN/LC_MESSAGES/libgnome-2.0.mo
+share/locale/zh_HK/LC_MESSAGES/libgnome-2.0.mo
share/locale/zh_TW/LC_MESSAGES/libgnome-2.0.mo
+@dirrmtry share/locale/zh_HK/LC_MESSAGES
+@dirrmtry share/locale/zh_HK
+@dirrmtry share/locale/tt/LC_MESSAGES
+@dirrmtry share/locale/tt
@dirrm include/libgnome-2.0/libgnome
@dirrm include/libgnome-2.0
%%PORTDOCS%%@dirrm %%DOCSDIR%%