aboutsummaryrefslogtreecommitdiffstats
path: root/x11/libxfce4menu/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/libxfce4menu/Makefile')
-rw-r--r--x11/libxfce4menu/Makefile36
1 files changed, 22 insertions, 14 deletions
diff --git a/x11/libxfce4menu/Makefile b/x11/libxfce4menu/Makefile
index 9ae5bbac8d41..cede6d6c0395 100644
--- a/x11/libxfce4menu/Makefile
+++ b/x11/libxfce4menu/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= libxfce4menu
-PORTVERSION= 4.12.1
-PORTREVISION= 2
+PORTVERSION= 4.14.1
CATEGORIES= x11 xfce
MASTER_SITES= XFCE
DISTNAME= libxfce4ui-${DISTVERSIONFULL}
@@ -15,13 +14,11 @@ COMMENT= Widgets library for the Xfce desktop environment
LICENSE= GPLv2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
- libfreetype.so:print/freetype2 \
- libdbus-glib-1.so:devel/dbus-glib \
- libdbus-1.so:devel/dbus
+ libfreetype.so:print/freetype2
USES= gettext-tools gmake gnome libtool pathfix pkgconfig \
- tar:bzip2 xfce
-USE_GNOME= cairo glib20 gtk20 intlhack intltool
+ tar:bzip2 xfce xorg
+USE_GNOME= cairo glib20 gtk30 intltool
USE_LDCONFIG= yes
USE_XFCE= xfconf
USE_XORG= ice sm x11
@@ -31,17 +28,24 @@ INSTALLS_ICONS= yes
CONFIGURE_ARGS= --with-vendor-info=${OPSYS} --without-html-dir
INSTALL_TARGET= install-strip
-PORTSCOUT= limit:^4\.12\.
+PORTSCOUT= limitw:1,even
-OPTIONS_DEFINE= GLADE GTK3 NLS STARTUP
-OPTIONS_DEFAULT= GTK3 STARTUP
+OPTIONS_DEFINE= GIR GLADE GTK2 NLS STARTUP VAPI
+OPTIONS_DEFAULT= GIR GTK2 STARTUP VAPI
OPTIONS_SUB= yes
-GLADE_CONFIGURE_ENABLE= gladeui
-GLADE_LIB_DEPENDS= libgladeui-1.so:devel/glade3
+GIR_DESC= Use Gobject Introspection
-GTK3_CONFIGURE_ENABLE= gtk3
-GTK3_USE= gnome=gtk30
+GIR_USE= gnome=introspection:build
+GIR_CONFIGURE_ON= --enable-introspection=yes
+GIR_CONFIGURE_OFF= --enable-introspection=no
+
+GLADE_CONFIGURE_ENABLE= gladeui2
+GLADE_LIB_DEPENDS= libgladeui-2.so:devel/glade
+GLADE_USE= gnome=libxml2
+
+GTK2_CONFIGURE_ENABLE= gtk2
+GTK2_USE= gnome=gtk20
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
@@ -50,4 +54,8 @@ STARTUP_CONFIGURE_ENABLE= startup-notification
STARTUP_DESC= Startup notification
STARTUP_LIB_DEPENDS= libstartup-notification-1.so:x11/startup-notification
+VAPI_BUILD_DEPENDS= vapigen:lang/vala
+VAPI_CONFIGURE_ENABLE= vala
+VAPI_IMPLIES= GIR
+
.include <bsd.port.mk>