aboutsummaryrefslogtreecommitdiffstats
path: root/x11/qt4-opengl/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/qt4-opengl/Makefile')
-rw-r--r--x11/qt4-opengl/Makefile6
1 files changed, 2 insertions, 4 deletions
diff --git a/x11/qt4-opengl/Makefile b/x11/qt4-opengl/Makefile
index 5bbe7cf165d8..06fc7a9437a2 100644
--- a/x11/qt4-opengl/Makefile
+++ b/x11/qt4-opengl/Makefile
@@ -19,7 +19,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt OpenGL library
USE_QT_VER= 4
-QT_COMPONENTS= qmake moc corelib gui
+QT_COMPONENTS= qmake_build moc_build corelib gui
QT_NONSTANDARD= yes
QT_DIST= yes
@@ -47,8 +47,6 @@ EXTRACT_AFTER_ARGS=| ${TAR} -xf - \
WRKSRC= ${WRKDIR}/${DISTNAME}/src/${PORTNAME}
CONFIGURE_WRKSRC=${WRKSRC}/../../
-.include <bsd.port.pre.mk>
-
pre-configure:
${CP} ${.CURDIR}/../../devel/qt4/files/configure ${CONFIGURE_WRKSRC}
${REINPLACE_CMD} -e 's|target.path.*|target.path=${PREFIX}/lib|g' \
@@ -67,4 +65,4 @@ post-configure:
-E -e 's|(.*location=).*uic|\1${PREFIX}/bin/uic-qt4|g' \
${WRKSRC}/../../lib/pkgconfig/*Qt*
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>