aboutsummaryrefslogtreecommitdiffstats
path: root/x11/trayer/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/trayer/Makefile')
-rw-r--r--x11/trayer/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/x11/trayer/Makefile b/x11/trayer/Makefile
index 6feb85453241..c510461a7cc6 100644
--- a/x11/trayer/Makefile
+++ b/x11/trayer/Makefile
@@ -3,6 +3,7 @@
# Whom: Alexey Mikhailov <karma@ez.pereslavl.ru>
#
# $FreeBSD$
+#
PORTNAME= trayer
PORTVERSION= 1.0
@@ -29,6 +30,10 @@ PORTDOCS= README CREDITS CHANGELOG
PLIST_FILES= bin/trayer
+post-patch:
+ @${REINPLACE_CMD} -e 's|-D.*_DISABLE_DEPRECATED||g' \
+ ${WRKSRC}/Makefile.common
+
post-install:
${MKDIR} ${DOCSDIR}
.if !defined(NOPORTDOCS)
@@ -36,4 +41,5 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
.endfor
.endif
+
.include <bsd.port.mk>