aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xbindkeys/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xbindkeys/Makefile')
-rw-r--r--x11/xbindkeys/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/x11/xbindkeys/Makefile b/x11/xbindkeys/Makefile
index 72aa51ad5980..447ad6245dc5 100644
--- a/x11/xbindkeys/Makefile
+++ b/x11/xbindkeys/Makefile
@@ -7,30 +7,29 @@
#
PORTNAME= xbindkeys
-PORTVERSION= 1.7.3
+PORTVERSION= 1.7.4
CATEGORIES= x11
MASTER_SITES= http://hocwp.free.fr/xbindkeys/
MAINTAINER= ports@FreeBSD.org
COMMENT= Allows you to launch shell commands under X with your keyboard
+OPTIONS= GUILE "Guile support" off \
+ TCLTK "Tcl/Tk support" off
+
USE_XLIB= yes
USE_GNOME= gnometarget
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= xbindkeys.1
+PLIST_FILES= bin/xbindkeys %%EXAMPLESDIR%%/xbindkeysrc
+PLIST_DIRS= %%EXAMPLESDIR%%
WISH= ${LOCALBASE}/bin/wish8.4
-OPTIONS= GUILE "Guile support" off \
- TCLTK "Tcl/Tk support" off
-
-PEXAMPLESDIR= ${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_FILES= bin/xbindkeys ${PEXAMPLESDIR}/xbindkeysrc
-PLIST_DIRS= ${PEXAMPLESDIR}
-
.include <bsd.port.pre.mk>
.if defined(WITH_GUILE)