aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xcape/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xcape/Makefile')
-rw-r--r--x11/xcape/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11/xcape/Makefile b/x11/xcape/Makefile
new file mode 100644
index 000000000000..3e95e819ef70
--- /dev/null
+++ b/x11/xcape/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= xcape
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.2-9
+DISTVERSIONSUFFIX= -g6ded5b4
+CATEGORIES= x11
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Configure modifier keys to act as other keys when pressed on their own
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USE_GITHUB= yes
+GH_ACCOUNT= alols
+
+USES= pkgconfig
+USE_XORG= x11 xtst
+
+MAKE_ARGS= PREFIX=${PREFIX} MANDIR=/man/man1
+
+PLIST_FILES= bin/xcape man/man1/xcape.1.gz
+
+post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/xcape
+
+.include <bsd.port.mk>