aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-conf/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-conf/Makefile')
-rw-r--r--x11/xfce4-conf/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/x11/xfce4-conf/Makefile b/x11/xfce4-conf/Makefile
index 003e17bff94e..e5c26c59ef8d 100644
--- a/x11/xfce4-conf/Makefile
+++ b/x11/xfce4-conf/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= xfce4-conf
-PORTVERSION= 4.12.1
+PORTVERSION= 4.14.1
CATEGORIES= x11 xfce
MASTER_SITES= XFCE
DISTNAME= xfconf-${DISTVERSIONFULL}
@@ -14,12 +14,10 @@ COMMENT= D-Bus-based configuration storage system
LICENSE= GPLv2
BUILD_DEPENDS= p5-XML-Parser>=2.44:textproc/p5-XML-Parser
-LIB_DEPENDS= libdbus-1.so:devel/dbus \
- libdbus-glib-1.so:devel/dbus-glib
-USES= gettext-tools gmake gnome libtool pathfix perl5 pkgconfig \
- tar:bzip2 xfce
-USE_GNOME= glib20 gtk20 intlhack intltool
+USES= compiler:c11 gettext-tools gmake gnome libtool pathfix perl5 \
+ pkgconfig tar:bzip2 xfce xorg
+USE_GNOME= glib20 intltool
USE_LDCONFIG= yes
USE_PERL5= build
USE_XFCE= libutil
@@ -29,9 +27,19 @@ GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
CONFIGURE_ARGS= --without-html-dir
-OPTIONS_DEFINE= PERL NLS
+PORTSCOUT= limitw:1,even
+
+OPTIONS_DEFINE= GIR NLS PERL VAPI
+OPTIONS_DEFAULT= GIR VAPI
OPTIONS_SUB= yes
+GIR_DESC= Use Gobject Introspection
+PERL_DESC= Perl scripting language bindings (deprecated)
+
+GIR_USE= gnome=introspection:build
+GIR_CONFIGURE_ON= --enable-introspection=yes
+GIR_CONFIGURE_OFF= --enable-introspection=no
+
NLS_CONFIGURE_ENABLE= nls
NLS_USES= gettext-runtime
@@ -39,6 +47,11 @@ PERL_BUILD_DEPENDS= p5-ExtUtils-Depends>=0.405:devel/p5-ExtUtils-Depends \
p5-ExtUtils-PkgConfig>=1.15:devel/p5-ExtUtils-PkgConfig \
p5-Glib2>=1.321:devel/p5-Glib2
PERL_CONFIGURE_ENABLE= perl-bindings
+PERL_LIB_DEPENDS= libdbus-1.so:devel/dbus
PERL_USE= perl5=run
+VAPI_BUILD_DEPENDS= vapigen:lang/vala
+VAPI_CONFIGURE_ENABLE= vala
+VAPA_IMPLIES= GIR
+
.include <bsd.port.mk>