aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-taskmanager/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-taskmanager/Makefile')
-rw-r--r--x11/xfce4-taskmanager/Makefile19
1 files changed, 12 insertions, 7 deletions
diff --git a/x11/xfce4-taskmanager/Makefile b/x11/xfce4-taskmanager/Makefile
index 0d8b61630db8..c7fe603bbc3f 100644
--- a/x11/xfce4-taskmanager/Makefile
+++ b/x11/xfce4-taskmanager/Makefile
@@ -6,24 +6,29 @@
#
PORTNAME= xfce4-taskmanager
-PORTVERSION= 0.4.0.r2
-PORTREVISION= 16
+PORTVERSION= 1.0.0
CATEGORIES= x11 xfce
-MASTER_SITES= http://freebsd.unixfreunde.de/sources/
-DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/-rc/}
+MASTER_SITES= ${MASTER_SITE_XFCE}
+MASTER_SITE_SUBDIR= src/apps/${PORTNAME}/${PORTVERSION:R}
DIST_SUBDIR= xfce4
MAINTAINER= miwi@FreeBSD.org
COMMENT= A task manager for XFCE
+LIB_DEPENDS= cairo.2:${PORTSDIR}/graphics/cairo \
+ wnck-1.22:${PORTSDIR}/x11-toolkits/libwnck
+
GNU_CONFIGURE= yes
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
-USE_XFCE= configenv libgui
+USE_GNOME= gnometarget gtk20 desktopfileutils intltool intlhack pkgconfig
post-patch:
- @${REINPLACE_CMD} -e 's|linux|freebsd|g; s|^CFLAGS = |&-lkvm -lm |' ${WRKSRC}/src/Makefile.in
+ @${REINPLACE_CMD} -e 's|prefix)/$$(DATADIRNAME)|datadir)|' \
+ ${WRKSRC}/po/Makefile.in.in
+
+post-install:
+ @-update-desktop-database
.include <bsd.port.mk>