aboutsummaryrefslogtreecommitdiffstats
path: root/x11/xfce4-xfapplet-plugin/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'x11/xfce4-xfapplet-plugin/Makefile')
-rw-r--r--x11/xfce4-xfapplet-plugin/Makefile29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11/xfce4-xfapplet-plugin/Makefile b/x11/xfce4-xfapplet-plugin/Makefile
new file mode 100644
index 000000000000..07c5cf115b8c
--- /dev/null
+++ b/x11/xfce4-xfapplet-plugin/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: xfapplet plugin for xfce4
+# Date created: 29 April 2006
+# Whom: Martin Wilke (freebsd@unixfreunde.de)
+#
+# $FreeBSD$
+#
+
+PORTNAME= xfce4-xfapplet-plugin
+PORTVERSION= 0.1.0
+CATEGORIES= x11 xfce
+MASTER_SITES= ftp://ftp.berlios.de/pub/xfce-goodies/panel-plugins/4.4/
+DIST_SUBDIR= xfce4
+
+MAINTAINER= freebsd@unixfreunde.de
+COMMENT= Xfapplet plugin for xfce
+
+LIB_DEPENDS= panelappletmm-2.6:${PORTSDIR}/x11-toolkits/libpanelappletmm
+
+GNU_CONFIGURE= yes
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_GMAKE= yes
+USE_GNOME= gnometarget gtk20 intltool intlhack orbit2 pkgconfig
+USE_XFCE= configenv libgui libutil panel
+USE_XLIB= yes
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
+.include <bsd.port.post.mk>