aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/Makefile1
-rw-r--r--x11/py-qt5-opengl/Makefile27
-rw-r--r--x11/py-qt5-opengl/pkg-descr4
-rw-r--r--x11/py-qt5-opengl/pkg-plist4
4 files changed, 36 insertions, 0 deletions
diff --git a/x11/Makefile b/x11/Makefile
index 15bc89139b48..b64d8235b1da 100644
--- a/x11/Makefile
+++ b/x11/Makefile
@@ -232,6 +232,7 @@
SUBDIR += printscreen
SUBDIR += props
SUBDIR += py-qt4-opengl
+ SUBDIR += py-qt5-opengl
SUBDIR += qimageblitz
SUBDIR += qt4-graphicssystems-opengl
SUBDIR += qt4-inputmethods
diff --git a/x11/py-qt5-opengl/Makefile b/x11/py-qt5-opengl/Makefile
new file mode 100644
index 000000000000..893416cbc360
--- /dev/null
+++ b/x11/py-qt5-opengl/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= opengl
+CATEGORIES= x11 devel python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtOpenGL module
+
+CONFIGURE_ARGS= --enable QtOpenGL
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run gui_run widgets_run
+USE_QT5= core gui opengl widgets qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtOpenGL API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/x11/py-qt5-opengl/pkg-descr b/x11/py-qt5-opengl/pkg-descr
new file mode 100644
index 000000000000..5b2a788a57f9
--- /dev/null
+++ b/x11/py-qt5-opengl/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtOpenGL module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/x11/py-qt5-opengl/pkg-plist b/x11/py-qt5-opengl/pkg-plist
new file mode 100644
index 000000000000..9e14cd09cce9
--- /dev/null
+++ b/x11/py-qt5-opengl/pkg-plist
@@ -0,0 +1,4 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtOpenGL.so
+%%PYQT_SIPDIR%%/QtOpenGL/QtOpenGLmod.sip
+%%PYQT_SIPDIR%%/QtOpenGL/qgl.sip
+%%API%%share/qt5/qsci/api/python/QtOpenGL.api