aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/nxcomp/Makefile2
-rw-r--r--x11/nxcomp/distinfo4
-rw-r--r--x11/nxcomp/files/patch-Types.h52
3 files changed, 3 insertions, 55 deletions
diff --git a/x11/nxcomp/Makefile b/x11/nxcomp/Makefile
index 43932a3bbbd6..e74033366e0a 100644
--- a/x11/nxcomp/Makefile
+++ b/x11/nxcomp/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= nxcomp
-PORTVERSION= 3.5.0.27
+PORTVERSION= 3.5.0.28
MASTER_SITES= http://code.x2go.org/releases/source/nx-libs/
CATEGORIES= x11 devel
DISTNAME= nx-libs-${PORTVERSION}-lite
diff --git a/x11/nxcomp/distinfo b/x11/nxcomp/distinfo
index 511b3f6c17a7..47d297f68019 100644
--- a/x11/nxcomp/distinfo
+++ b/x11/nxcomp/distinfo
@@ -1,2 +1,2 @@
-SHA256 (nx-libs-3.5.0.27-lite.tar.gz) = efbf6eed02b5eb2892828e2237dff4591442e96d0ac83f3d75c62a15101d6a27
-SIZE (nx-libs-3.5.0.27-lite.tar.gz) = 513262
+SHA256 (nx-libs-3.5.0.28-lite.tar.gz) = f0f47a4fe63a20d39a51e1446bb86ffaec70b816853e6db28d2519e72d428a7c
+SIZE (nx-libs-3.5.0.28-lite.tar.gz) = 519365
diff --git a/x11/nxcomp/files/patch-Types.h b/x11/nxcomp/files/patch-Types.h
deleted file mode 100644
index 6e6cf884d60d..000000000000
--- a/x11/nxcomp/files/patch-Types.h
+++ /dev/null
@@ -1,52 +0,0 @@
-Description: In Types.h, don't use STL internals on libc++.
-Author: Clemens Lang <cal@macports.org>
-Abstract:
- The nx-libs-lite package does not compile on OS X Mavericks because
- Apple's clang compilers now default to compiling against the libc++ STL
- rather than (their outdated copy of) libstdc++.
- .
- While the compiler still allows changing that, we should not rely on
- this being possible forever.
- .
- The compiler chokes in Types.h, specifically the clear() methods in
- subclasses of vectors that use implementation details of the GNU STL.
- The attached patch fixes these compilation issues by not overriding the
- clear() method when compiling against libc++, since the libc++ headers
- seem to do essentially the same as the overriden method.
---- Types.h 2013-11-05 01:35:22.000000000 +0100
-+++ Types.h 2013-11-05 01:37:30.000000000 +0100
-@@ -55,6 +55,9 @@
- return &*(vector < unsigned char >::begin());
- }
-
-+ // Avoid overriding clear() when using libc++. Fiddling with STL internals
-+ // doesn't really seem like a good idea to me anyway.
-+ #ifndef _LIBCPP_VECTOR
- void clear()
- {
- #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H)
-@@ -95,12 +98,16 @@
-
- #endif /* #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H) */
- }
-+ #endif /* #ifdef _LIBCPP_VECTOR */
- };
-
- class T_messages : public vector < Message * >
- {
- public:
-
-+ // Avoid overriding clear() when using libc++. Fiddling with STL internals
-+ // doesn't really seem like a good idea to me anyway.
-+ #ifndef _LIBCPP_VECTOR
- void clear()
- {
- #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H)
-@@ -141,6 +148,7 @@
-
- #endif /* #if defined(__STL_USE_STD_ALLOCATORS) || defined(__GLIBCPP_INTERNAL_VECTOR_H) */
- }
-+ #endif /* #ifndef _LIBCPP_VECTOR */
- };
-
- typedef md5_byte_t * T_checksum;