aboutsummaryrefslogtreecommitdiffstats
path: root/x11
diff options
context:
space:
mode:
Diffstat (limited to 'x11')
-rw-r--r--x11/kdelibs3/Makefile1
-rw-r--r--x11/kdelibs3/files/patch-kdesu-su.cpp13
-rw-r--r--x11/kdelibs4/Makefile1
-rw-r--r--x11/kdelibs4/files/patch-kdesu-su.cpp13
4 files changed, 28 insertions, 0 deletions
diff --git a/x11/kdelibs3/Makefile b/x11/kdelibs3/Makefile
index 98ba5d9f658a..f996c1cd6231 100644
--- a/x11/kdelibs3/Makefile
+++ b/x11/kdelibs3/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs3/files/patch-kdesu-su.cpp b/x11/kdelibs3/files/patch-kdesu-su.cpp
new file mode 100644
index 000000000000..237eac59590b
--- /dev/null
+++ b/x11/kdelibs3/files/patch-kdesu-su.cpp
@@ -0,0 +1,13 @@
+--- kdesu/su.cpp 2004/03/26 23:26:45 1.32.2.2
++++ kdesu/su.cpp 2004/04/13 13:32:27 1.32.2.3
+@@ -78,9 +78,9 @@ int SuProcess::exec(const char *password
+ args += "root";
+ else
+ args += m_User;
+- args += "-";
+ args += "-c";
+ args += QCString(__KDE_BINDIR) + "/kdesu_stub";
++ args += "-";
+
+ QCString command = __PATH_SU;
+ if (::access(__PATH_SU, X_OK) != 0)
diff --git a/x11/kdelibs4/Makefile b/x11/kdelibs4/Makefile
index 98ba5d9f658a..f996c1cd6231 100644
--- a/x11/kdelibs4/Makefile
+++ b/x11/kdelibs4/Makefile
@@ -8,6 +8,7 @@
PORTNAME= kdelibs
PORTVERSION= ${KDE_VERSION}
+PORTREVISION= 1
CATEGORIES= x11 kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
diff --git a/x11/kdelibs4/files/patch-kdesu-su.cpp b/x11/kdelibs4/files/patch-kdesu-su.cpp
new file mode 100644
index 000000000000..237eac59590b
--- /dev/null
+++ b/x11/kdelibs4/files/patch-kdesu-su.cpp
@@ -0,0 +1,13 @@
+--- kdesu/su.cpp 2004/03/26 23:26:45 1.32.2.2
++++ kdesu/su.cpp 2004/04/13 13:32:27 1.32.2.3
+@@ -78,9 +78,9 @@ int SuProcess::exec(const char *password
+ args += "root";
+ else
+ args += m_User;
+- args += "-";
+ args += "-c";
+ args += QCString(__KDE_BINDIR) + "/kdesu_stub";
++ args += "-";
+
+ QCString command = __PATH_SU;
+ if (::access(__PATH_SU, X_OK) != 0)