aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2010-12-21 01:41:43 +0800
committerthierry <thierry@FreeBSD.org>2010-12-21 01:41:43 +0800
commit02d949365104db349612f56eba31328f63dab76a (patch)
treea5237872d907cb1b2cb1520e41b4945247d77be7
parentff4708a03864605c3bebeb076aaa655e4c5e3b59 (diff)
downloadfreebsd-ports-graphics-02d949365104db349612f56eba31328f63dab76a.tar.gz
freebsd-ports-graphics-02d949365104db349612f56eba31328f63dab76a.tar.zst
freebsd-ports-graphics-02d949365104db349612f56eba31328f63dab76a.zip
This project uses Python and Qt to create a small software to download podcasts
and videos from French websites. It uses plugins to enlarge software possibilities.
-rw-r--r--french/Makefile1
-rw-r--r--french/tvdownloader/Makefile40
-rw-r--r--french/tvdownloader/distinfo2
-rw-r--r--french/tvdownloader/files/patch-Makefile44
-rw-r--r--french/tvdownloader/files/patch-tvdownloader.sh27
-rw-r--r--french/tvdownloader/pkg-descr10
-rw-r--r--french/tvdownloader/pkg-plist209
7 files changed, 333 insertions, 0 deletions
diff --git a/french/Makefile b/french/Makefile
index d855a5a8c43..361000be033 100644
--- a/french/Makefile
+++ b/french/Makefile
@@ -31,6 +31,7 @@
SUBDIR += mozilla-flp
SUBDIR += php_doc
SUBDIR += plgrenouille
+ SUBDIR += tvdownloader
SUBDIR += verbiste
SUBDIR += xtel
diff --git a/french/tvdownloader/Makefile b/french/tvdownloader/Makefile
new file mode 100644
index 00000000000..954cd8a46c2
--- /dev/null
+++ b/french/tvdownloader/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: tvdownloader
+# Date created: Fri 19 dec 2010
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= tvdownloader
+PORTVERSION= 0.7.2
+CATEGORIES= french multimedia
+MASTER_SITES= ${MASTER_SITE_GOOGLE_CODE}
+MASTER_SITE_SUBDIR=
+
+MAINTAINER= thierry@FreeBSD.org
+COMMENT= Download podcasts and videos from French websites
+
+RUN_DEPENDS= msdl:${PORTSDIR}/multimedia/msdl \
+ rtmpdump:${PORTSDIR}/multimedia/rtmpdump \
+ ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \
+ ${PYTHON_SITELIBDIR}/Crypto/__init__.py:${PORTSDIR}/security/py-pycrypto\
+ ${PYTHON_SITELIBDIR}/${MECHA_EGG}:${PORTSDIR}/www/py-mechanize
+
+MECHA_VER= 0.2.4
+MECHA_EGG= mechanize-${MECHA_VER}-${PYTHON_VERSION:S/thon//}${PYEASYINSTALL_OSARCH}.egg
+
+USE_PYTHON= yes
+ALL_TARGET= build
+
+LICENSE= GPLv2
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|%%PYTHON_CMD%%|${PYTHON_CMD}|' \
+ ${WRKSRC}/tvdownloader.sh
+.if defined(NOPORTDOCS)
+ ${REINPLACE_CMD} -e 's|%%DOC%%|#|' ${WRKSRC}/Makefile
+.else
+ ${REINPLACE_CMD} -e 's|%%DOC%%||' ${WRKSRC}/Makefile
+.endif
+
+.include <bsd.port.mk>
diff --git a/french/tvdownloader/distinfo b/french/tvdownloader/distinfo
new file mode 100644
index 00000000000..a8742d03066
--- /dev/null
+++ b/french/tvdownloader/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tvdownloader-0.7.2.tar.gz) = 5faa399a2b2529f5ab1f7f7dc91810f6bb3acdedc82246083576b10fbc31dee7
+SIZE (tvdownloader-0.7.2.tar.gz) = 172523
diff --git a/french/tvdownloader/files/patch-Makefile b/french/tvdownloader/files/patch-Makefile
new file mode 100644
index 00000000000..baa14dc332f
--- /dev/null
+++ b/french/tvdownloader/files/patch-Makefile
@@ -0,0 +1,44 @@
+--- Makefile.orig 2010-10-16 17:18:06.000000000 +0200
++++ Makefile 2010-12-19 22:59:31.000000000 +0100
+@@ -6,7 +6,7 @@
+ DATADIR ?= $(PREFIX)/share
+
+ # Commande pour l'installation
+-INSTALL = install -m 755
++INSTALL = install -m 644
+
+
+ # Compilation
+@@ -14,7 +14,7 @@
+ # ByteCode
+ @python -c "import compileall ; compileall.compile_dir( 'src' )"
+ # On modifie le lanceur
+- sed -i 's|__DATADIR__|$(DESTDIR)$(DATADIR)|g' tvdownloader.sh
++ sed -i -e 's|__DATADIR__|$(DESTDIR)$(DATADIR)|g' tvdownloader.sh
+
+ # Installation
+ install :
+@@ -33,18 +33,14 @@
+ $(INSTALL) tvdownloader.png $(DESTDIR)$(DATADIR)/pixmaps/
+
+ # On met en place la doc
+- mkdir -p $(DESTDIR)$(DATADIR)/doc/tvdownloader
+- cp -ar doc/* $(DESTDIR)$(DATADIR)/doc/tvdownloader/
+- # On change les droits
+- chmod -R 0755 $(DESTDIR)$(DATADIR)/doc/tvdownloader
++ %%DOC%%mkdir -p $(DESTDIR)$(DATADIR)/doc/tvdownloader
++ %%DOC%%cp -R doc/* $(DESTDIR)$(DATADIR)/doc/tvdownloader/
+
+ # On met en place le code
+ mkdir -p $(DESTDIR)$(DATADIR)/tvdownloader
+- cp -ar src/* $(DESTDIR)$(DATADIR)/tvdownloader/
+- # On change les droits
+- chmod -R 0755 $(DESTDIR)$(DATADIR)/tvdownloader
++ cp -R src/* $(DESTDIR)$(DATADIR)/tvdownloader/
+
+ # Nettoyage
+ clean :
+ echo "Nothing"
+- #~ @rm -vf {src,src/fonctions,src/GUI,src/GUI/Qt,src/ico,src/lib,src/plugins}/*{pyc,pyo,~}
+\ No newline at end of file
++ #~ @rm -vf {src,src/fonctions,src/GUI,src/GUI/Qt,src/ico,src/lib,src/plugins}/*{pyc,pyo,~}
diff --git a/french/tvdownloader/files/patch-tvdownloader.sh b/french/tvdownloader/files/patch-tvdownloader.sh
new file mode 100644
index 00000000000..343a7f9bf06
--- /dev/null
+++ b/french/tvdownloader/files/patch-tvdownloader.sh
@@ -0,0 +1,27 @@
+--- tvdownloader.sh.orig 2010-10-16 16:27:16.000000000 +0200
++++ tvdownloader.sh 2010-12-19 23:38:13.000000000 +0100
+@@ -1,20 +1,5 @@
+-#!/bin/bash
++#! /bin/sh
++# $FreeBSD$
+
+ cd "__DATADIR__/tvdownloader/"
+-
+-if [ ! -z "`python --version 2>&1 | grep 'Python 2'`" ]
+-then
+- python main.py "$*"
+-else
+- if [ -x "/usr/bin/python2.7" ]
+- then
+- python2.7 main.py "$*"
+- else
+- if [ -x "/usr/bin/python2.6" ]
+- then
+- python2.6 main.py "$*"
+- else
+- echo "Erreur : impossible de trouver une version de Python 2"
+- fi
+- fi
+-fi
+\ No newline at end of file
++exec %%PYTHON_CMD%% main.py
diff --git a/french/tvdownloader/pkg-descr b/french/tvdownloader/pkg-descr
new file mode 100644
index 00000000000..ad57e845ab4
--- /dev/null
+++ b/french/tvdownloader/pkg-descr
@@ -0,0 +1,10 @@
+This project uses Python and Qt to create a small software to download podcasts
+and videos from French websites. It uses plugins to enlarge software
+possibilities.
+
+TVDownloader est un projet qui a pour but de permettre le téléchargement de
+podcasts et d'émissions librement disponibles sur Internet. On retrouvera, en
+autre, les podcasts de grands groupes radio comme Radio France ou télévisuel
+comme France Télévision.
+
+WWW: http://code.google.com/p/tvdownloader/
diff --git a/french/tvdownloader/pkg-plist b/french/tvdownloader/pkg-plist
new file mode 100644
index 00000000000..0b5439297f1
--- /dev/null
+++ b/french/tvdownloader/pkg-plist
@@ -0,0 +1,209 @@
+bin/tvdownloader
+share/applications/tvdownload.desktop
+share/pixmaps/tvdownloader.png
+%%PORTDOCS%%%%DOCSDIR%%/annotated.html
+%%PORTDOCS%%%%DOCSDIR%%/bc_s.png
+%%PORTDOCS%%%%DOCSDIR%%/classAPI_1_1API-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classAPI_1_1API.html
+%%PORTDOCS%%%%DOCSDIR%%/classFichier_1_1Fichier-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classFichier_1_1Fichier.html
+%%PORTDOCS%%%%DOCSDIR%%/classPlugin_1_1Plugin-members.html
+%%PORTDOCS%%%%DOCSDIR%%/classPlugin_1_1Plugin.html
+%%PORTDOCS%%%%DOCSDIR%%/classes.html
+%%PORTDOCS%%%%DOCSDIR%%/closed.png
+%%PORTDOCS%%%%DOCSDIR%%/deprecated.html
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.css
+%%PORTDOCS%%%%DOCSDIR%%/doxygen.png
+%%PORTDOCS%%%%DOCSDIR%%/functions.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_func.html
+%%PORTDOCS%%%%DOCSDIR%%/functions_vars.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/installdox
+%%PORTDOCS%%%%DOCSDIR%%/nav_f.png
+%%PORTDOCS%%%%DOCSDIR%%/nav_h.png
+%%PORTDOCS%%%%DOCSDIR%%/open.png
+%%PORTDOCS%%%%DOCSDIR%%/pages.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_5f.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_61.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_63.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_64.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_66.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_67.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_69.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_6c.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_6e.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_6f.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_70.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_72.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_73.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_75.html
+%%PORTDOCS%%%%DOCSDIR%%/search/all_76.html
+%%PORTDOCS%%%%DOCSDIR%%/search/classes_61.html
+%%PORTDOCS%%%%DOCSDIR%%/search/classes_66.html
+%%PORTDOCS%%%%DOCSDIR%%/search/classes_70.html
+%%PORTDOCS%%%%DOCSDIR%%/search/close.png
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_5f.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_61.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_63.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_67.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_6c.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_6f.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_72.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_73.html
+%%PORTDOCS%%%%DOCSDIR%%/search/functions_76.html
+%%PORTDOCS%%%%DOCSDIR%%/search/mag_sel.png
+%%PORTDOCS%%%%DOCSDIR%%/search/nomatches.html
+%%PORTDOCS%%%%DOCSDIR%%/search/search.css
+%%PORTDOCS%%%%DOCSDIR%%/search/search.js
+%%PORTDOCS%%%%DOCSDIR%%/search/search_l.png
+%%PORTDOCS%%%%DOCSDIR%%/search/search_m.png
+%%PORTDOCS%%%%DOCSDIR%%/search/search_r.png
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_61.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_64.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_66.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_69.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_6c.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_6e.html
+%%PORTDOCS%%%%DOCSDIR%%/search/variables_75.html
+%%PORTDOCS%%%%DOCSDIR%%/tab_a.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_b.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_h.png
+%%PORTDOCS%%%%DOCSDIR%%/tab_s.png
+%%PORTDOCS%%%%DOCSDIR%%/tabs.css
+%%DATADIR%%/API.py
+%%DATADIR%%/API.pyc
+%%DATADIR%%/APIPrive.py
+%%DATADIR%%/APIPrive.pyc
+%%DATADIR%%/CLI/Option.py
+%%DATADIR%%/CLI/Option.pyc
+%%DATADIR%%/CLI/Screen.py
+%%DATADIR%%/CLI/Screen.pyc
+%%DATADIR%%/CLI/__init__.py
+%%DATADIR%%/CLI/__init__.pyc
+%%DATADIR%%/CLI/cli.py
+%%DATADIR%%/CLI/cli.pyc
+%%DATADIR%%/CLI/getch.py
+%%DATADIR%%/CLI/getch.pyc
+%%DATADIR%%/CLIDialog/CLIDialog.py
+%%DATADIR%%/CLIDialog/CLIDialog.pyc
+%%DATADIR%%/CLIDialog/__init__.py
+%%DATADIR%%/CLIDialog/__init__.pyc
+%%DATADIR%%/CLIDialog/dialog.sh
+%%DATADIR%%/COPYING
+%%DATADIR%%/Downloader.py
+%%DATADIR%%/Downloader.pyc
+%%DATADIR%%/Fichier.py
+%%DATADIR%%/Fichier.pyc
+%%DATADIR%%/GUI/AProposDialog.py
+%%DATADIR%%/GUI/AProposDialog.pyc
+%%DATADIR%%/GUI/ConvertQString.py
+%%DATADIR%%/GUI/ConvertQString.pyc
+%%DATADIR%%/GUI/FenetreAttenteProgressDialog.py
+%%DATADIR%%/GUI/FenetreAttenteProgressDialog.pyc
+%%DATADIR%%/GUI/MainWindow.py
+%%DATADIR%%/GUI/MainWindow.pyc
+%%DATADIR%%/GUI/PreferencePluginDialog.py
+%%DATADIR%%/GUI/PreferencePluginDialog.pyc
+%%DATADIR%%/GUI/PreferencesDialog.py
+%%DATADIR%%/GUI/PreferencesDialog.pyc
+%%DATADIR%%/GUI/Qt/MyQPushButton.py
+%%DATADIR%%/GUI/Qt/MyQPushButton.pyc
+%%DATADIR%%/GUI/Qt/MyQTableWidget.py
+%%DATADIR%%/GUI/Qt/MyQTableWidget.pyc
+%%DATADIR%%/GUI/Qt/__init__.py
+%%DATADIR%%/GUI/Qt/__init__.pyc
+%%DATADIR%%/GUI/Signaux.py
+%%DATADIR%%/GUI/Signaux.pyc
+%%DATADIR%%/GUI/UpdateManagerDialog.py
+%%DATADIR%%/GUI/UpdateManagerDialog.pyc
+%%DATADIR%%/GUI/__init__.py
+%%DATADIR%%/GUI/__init__.pyc
+%%DATADIR%%/Historique.py
+%%DATADIR%%/Historique.pyc
+%%DATADIR%%/Makefile
+%%DATADIR%%/Navigateur.py
+%%DATADIR%%/Navigateur.pyc
+%%DATADIR%%/Option.py
+%%DATADIR%%/Option.pyc
+%%DATADIR%%/Plugin.py
+%%DATADIR%%/Plugin.pyc
+%%DATADIR%%/PluginManager.py
+%%DATADIR%%/PluginManager.pyc
+%%DATADIR%%/Preferences.py
+%%DATADIR%%/Preferences.pyc
+%%DATADIR%%/UpdateManager.py
+%%DATADIR%%/UpdateManager.pyc
+%%DATADIR%%/fonctions/__init__.py
+%%DATADIR%%/fonctions/__init__.pyc
+%%DATADIR%%/fonctions/urlToRtmpdump.py
+%%DATADIR%%/fonctions/urlToRtmpdump.pyc
+%%DATADIR%%/ico/TVDownloader.png
+%%DATADIR%%/ico/gtk-about.svg
+%%DATADIR%%/ico/gtk-add.svg
+%%DATADIR%%/ico/gtk-apply.svg
+%%DATADIR%%/ico/gtk-cancel.svg
+%%DATADIR%%/ico/gtk-delete-full.svg
+%%DATADIR%%/ico/gtk-file.svg
+%%DATADIR%%/ico/gtk-folder.svg
+%%DATADIR%%/ico/gtk-go-down.svg
+%%DATADIR%%/ico/gtk-go-up.svg
+%%DATADIR%%/ico/gtk-jump-to-ltr.svg
+%%DATADIR%%/ico/gtk-jump-to-rtl.svg
+%%DATADIR%%/ico/gtk-media-play-ltr.svg
+%%DATADIR%%/ico/gtk-media-stop.svg
+%%DATADIR%%/ico/gtk-preferences.svg
+%%DATADIR%%/ico/gtk-quit.svg
+%%DATADIR%%/ico/gtk-refresh.svg
+%%DATADIR%%/ico/gtk-save.svg
+%%DATADIR%%/img/banniere.png
+%%DATADIR%%/img/gtk-dialog-question.svg
+%%DATADIR%%/lib/__init__.py
+%%DATADIR%%/lib/__init__.pyc
+%%DATADIR%%/lib/dialog.py
+%%DATADIR%%/lib/dialog.pyc
+%%DATADIR%%/main.py
+%%DATADIR%%/main.pyc
+%%DATADIR%%/plugins/Arte.py
+%%DATADIR%%/plugins/Arte.pyc
+%%DATADIR%%/plugins/CanalPlus.py
+%%DATADIR%%/plugins/CanalPlus.pyc
+%%DATADIR%%/plugins/Europe1.py
+%%DATADIR%%/plugins/Europe1.pyc
+%%DATADIR%%/plugins/FranceInter.py
+%%DATADIR%%/plugins/FranceInter.pyc
+%%DATADIR%%/plugins/M6Replay.py
+%%DATADIR%%/plugins/M6Replay.pyc
+%%DATADIR%%/plugins/Pluzz.py
+%%DATADIR%%/plugins/Pluzz.pyc
+%%DATADIR%%/plugins/Podcasts.py
+%%DATADIR%%/plugins/Podcasts.pyc
+%%DATADIR%%/plugins/RadioFrance.py
+%%DATADIR%%/plugins/RadioFrance.pyc
+%%DATADIR%%/plugins/W9Replay.py
+%%DATADIR%%/plugins/W9Replay.pyc
+%%DATADIR%%/plugins/__init__.py
+%%DATADIR%%/plugins/__init__.pyc
+%%DATADIR%%/tests/HistoriqueTests.py
+%%DATADIR%%/tests/HistoriqueTests.pyc
+%%DATADIR%%/tests/PreferencesTests.py
+%%DATADIR%%/tests/PreferencesTests.pyc
+%%DATADIR%%/tests/TesteDebit.py
+%%DATADIR%%/tests/TesteDebit.pyc
+%%DATADIR%%/tests/__init__.py
+%%DATADIR%%/tests/__init__.pyc
+%%DATADIR%%/tests/tests.py
+%%DATADIR%%/tests/tests.pyc
+@dirrm %%DATADIR%%/tests
+@dirrm %%DATADIR%%/plugins
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%/img
+@dirrm %%DATADIR%%/ico
+@dirrm %%DATADIR%%/fonctions
+@dirrm %%DATADIR%%/GUI/Qt
+@dirrm %%DATADIR%%/GUI
+@dirrm %%DATADIR%%/CLIDialog
+@dirrm %%DATADIR%%/CLI
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/search
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrmtry share/applications