aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorperky <perky@FreeBSD.org>2002-07-02 02:42:09 +0800
committerperky <perky@FreeBSD.org>2002-07-02 02:42:09 +0800
commit03633a8f17756b002c6548aaeb9e0348866cac6a (patch)
tree3eeb287b3ba0b348b8c60f397c742db2f214dc1e
parente4d2e285f706edce2e937afd7beb2992317600a5 (diff)
downloadfreebsd-ports-graphics-03633a8f17756b002c6548aaeb9e0348866cac6a.tar.gz
freebsd-ports-graphics-03633a8f17756b002c6548aaeb9e0348866cac6a.tar.zst
freebsd-ports-graphics-03633a8f17756b002c6548aaeb9e0348866cac6a.zip
Add pyrex 0.3.2,
programming Language for writing Python extension modules. PR: 36995 Submitted by: me
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pyrex/Makefile44
-rw-r--r--devel/pyrex/distinfo1
-rw-r--r--devel/pyrex/files/setup.py8
-rw-r--r--devel/pyrex/pkg-comment1
-rw-r--r--devel/pyrex/pkg-descr5
-rw-r--r--devel/pyrex/pkg-plist92
7 files changed, 152 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 3ccf43e62c3..871e20c5517 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -613,6 +613,7 @@
SUBDIR += py-vmaps
SUBDIR += py-xoltar-toolkit
SUBDIR += pychecker
+ SUBDIR += pyrex
SUBDIR += qt-designer
SUBDIR += qtez
SUBDIR += qtk
diff --git a/devel/pyrex/Makefile b/devel/pyrex/Makefile
new file mode 100644
index 00000000000..e8a21a95503
--- /dev/null
+++ b/devel/pyrex/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: pyrex
+# Date created: 11 April 2002
+# Whom: Hye-Shik Chang
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyrex
+PORTVERSION= 0.3.2
+CATEGORIES= devel lang python
+MASTER_SITES= http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
+PKGNAMEPREFIX= ${PYTHONPKGNAMEPREFIX}
+DISTNAME= Pyrex${PORTVERSION}
+
+MAINTAINER= perky@FreeBSD.org
+
+BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/Plex/__init__.py:${PORTSDIR}/textproc/py-plex
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/Plex/__init__.py:${PORTSDIR}/textproc/py-plex
+
+USE_PYTHON= yes
+USE_PYDISTUTILS=yes
+USE_REINPLACE= yes
+
+post-patch:
+ @${SED} -e 's|%%PORTVERSION%%|${PORTVERSION}|g' ${FILESDIR}/setup.py \
+ > ${WRKSRC}/setup.py
+ @${REINPLACE_CMD} -e 's|^PYINCLUDE =.*|PYINCLUDE=${PYTHON_INCLUDEDIR}|g' \
+ -e 's|\.\./py|${PREFIX}/bin/py|g' ${WRKSRC}/Demos/Makefile
+ @${RM} -f ${WRKSRC}/Demos/Makefile.bak
+
+post-install:
+ @# precompile lexicon pickle
+ @cd ${WRKSRC}/Demos && ${PYTHON_CMD} ${PREFIX}/bin/pyrexc primes.pyx
+
+.if !defined(NOPORTDOCS)
+ @cd ${WRKSRC}/Demos && ${MAKE} clean
+
+ @${MKDIR} ${DOCSDIR}
+ @cd ${WRKSRC}/Doc && ${INSTALL_DATA} ./* ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @cd ${WRKSRC}/Demos && ${INSTALL_DATA} ./* ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/pyrex/distinfo b/devel/pyrex/distinfo
new file mode 100644
index 00000000000..6e0269a8e9b
--- /dev/null
+++ b/devel/pyrex/distinfo
@@ -0,0 +1 @@
+MD5 (Pyrex0.3.2.tar.gz) = 735e45b31e288d473c54e8601baa8d3e
diff --git a/devel/pyrex/files/setup.py b/devel/pyrex/files/setup.py
new file mode 100644
index 00000000000..7ab6cb95891
--- /dev/null
+++ b/devel/pyrex/files/setup.py
@@ -0,0 +1,8 @@
+from distutils.core import setup
+
+setup(
+ name = 'pyrex',
+ version = "%%PORTVERSION%%",
+ packages = ['Pyrex', 'Pyrex.Compiler', 'Pyrex.Mac'],
+ scripts = ['pyrexc'],
+ )
diff --git a/devel/pyrex/pkg-comment b/devel/pyrex/pkg-comment
new file mode 100644
index 00000000000..7f0b9f7dcf7
--- /dev/null
+++ b/devel/pyrex/pkg-comment
@@ -0,0 +1 @@
+Programming Language for writing Python extension modules
diff --git a/devel/pyrex/pkg-descr b/devel/pyrex/pkg-descr
new file mode 100644
index 00000000000..13be365829d
--- /dev/null
+++ b/devel/pyrex/pkg-descr
@@ -0,0 +1,5 @@
+Pyrex is a language specially designed for writing Python extension
+modules. It's designed to bridge the gap between the nice, high-level,
+easy-to-use world of Python and the messy, low-level world of C.
+
+WWW: http://www.cosc.canterbury.ac.nz/~greg/python/Pyrex/
diff --git a/devel/pyrex/pkg-plist b/devel/pyrex/pkg-plist
new file mode 100644
index 00000000000..825478b7d19
--- /dev/null
+++ b/devel/pyrex/pkg-plist
@@ -0,0 +1,92 @@
+bin/pyrexc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Code.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Code.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Code.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/DebugFlags.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Errors.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/ExprNodes.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Lexicon.pickle
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Main.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Main.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Main.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Naming.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Naming.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Naming.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Nodes.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Nodes.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Nodes.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Parsing.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Parsing.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Parsing.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/PyrexTypes.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/PyrexTypes.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/PyrexTypes.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Scanning.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Scanning.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Scanning.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Symtab.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Symtab.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/Symtab.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/TypeSlots.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/TypeSlots.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/TypeSlots.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/__init__.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Compiler/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/Finder_Std_Suite.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/Finder_Std_Suite.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/Finder_Std_Suite.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MPW_Misc_Suite.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MPW_Misc_Suite.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MPW_Misc_Suite.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacSystem.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacSystem.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacSystem.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacTesting.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacTesting.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacTesting.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacUtils.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacUtils.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/MacUtils.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PS_Misc_Suite.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PS_Misc_Suite.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PS_Misc_Suite.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PyServerMain.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PyServerMain.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/PyServerMain.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/TS_Misc_Suite.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/TS_Misc_Suite.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/TS_Misc_Suite.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/__init__.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Mac/__init__.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Testing.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Testing.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Testing.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/Utils.py
+%%PYTHON_SITELIBDIR%%/Pyrex/Utils.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/Utils.pyo
+%%PYTHON_SITELIBDIR%%/Pyrex/__init__.py
+%%PYTHON_SITELIBDIR%%/Pyrex/__init__.pyc
+%%PYTHON_SITELIBDIR%%/Pyrex/__init__.pyo
+@dirrm %%PYTHON_SITELIBDIR%%/Pyrex/Mac
+@dirrm %%PYTHON_SITELIBDIR%%/Pyrex/Compiler
+@dirrm %%PYTHON_SITELIBDIR%%/Pyrex
+%%PORTDOCS%%share/doc/pyrex/About.html
+%%PORTDOCS%%share/doc/pyrex/overview.html
+%%PORTDOCS%%share/doc/pyrex/primes.c
+%%PORTDOCS%%share/doc/pyrex/special_methods.html
+%%PORTDOCS%%share/examples/pyrex/Makefile
+%%PORTDOCS%%share/examples/pyrex/primes.pyx
+%%PORTDOCS%%share/examples/pyrex/pyprimes.py
+%%PORTDOCS%%share/examples/pyrex/run_primes.py
+%%PORTDOCS%%share/examples/pyrex/run_spam.py
+%%PORTDOCS%%share/examples/pyrex/spam.pyx
+%%PORTDOCS%%@dirrm share/examples/pyrex
+%%PORTDOCS%%@dirrm share/doc/pyrex