aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrafan <rafan@FreeBSD.org>2007-01-18 14:21:18 +0800
committerrafan <rafan@FreeBSD.org>2007-01-18 14:21:18 +0800
commit037e4b73459077ae563a38d1d45d608ff75454e2 (patch)
tree182e39ad6fce25900291d0fac1cf6e9c46f1dd9b
parent54f3ff2558db9d3c9adf4c09f47df6b9e2c9a2a7 (diff)
downloadfreebsd-ports-graphics-037e4b73459077ae563a38d1d45d608ff75454e2.tar.gz
freebsd-ports-graphics-037e4b73459077ae563a38d1d45d608ff75454e2.tar.zst
freebsd-ports-graphics-037e4b73459077ae563a38d1d45d608ff75454e2.zip
Add p5-AutoLoader, a module that loads subroutines only on demand.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-AutoLoader/Makefile28
-rw-r--r--devel/p5-AutoLoader/distinfo3
-rw-r--r--devel/p5-AutoLoader/pkg-descr5
-rw-r--r--devel/p5-AutoLoader/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 748a6652eb3..82f72495a3d 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -818,6 +818,7 @@
SUBDIR += p5-Attribute-Handlers
SUBDIR += p5-Attribute-Handlers-Prospective
SUBDIR += p5-Attribute-Persistent
+ SUBDIR += p5-AutoLoader
SUBDIR += p5-B-Deobfuscate
SUBDIR += p5-B-Graph
SUBDIR += p5-B-Keywords
diff --git a/devel/p5-AutoLoader/Makefile b/devel/p5-AutoLoader/Makefile
new file mode 100644
index 00000000000..eebf16523e5
--- /dev/null
+++ b/devel/p5-AutoLoader/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-AutoLoader
+# Date created: Jan 18 2007
+# Whom: Rong-En Fan <rafan@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= AutoLoader
+PORTVERSION= 5.63
+CATEGORIES= devel perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= rafan@FreeBSD.org
+COMMENT= Load subroutines only on demand
+
+PERL_CONFIGURE= yes
+
+MAN3= AutoLoader.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500601
+IGNORE= this program only support perl 5.6.1 or above
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/devel/p5-AutoLoader/distinfo b/devel/p5-AutoLoader/distinfo
new file mode 100644
index 00000000000..038ec7491f4
--- /dev/null
+++ b/devel/p5-AutoLoader/distinfo
@@ -0,0 +1,3 @@
+MD5 (AutoLoader-5.63.tar.gz) = e1c37fc322a309ec9881ad83a2487bb6
+SHA256 (AutoLoader-5.63.tar.gz) = aded4965e59c263c1d76ffc4843e15484a4a160081697ce00c2b25c596f12a8c
+SIZE (AutoLoader-5.63.tar.gz) = 15982
diff --git a/devel/p5-AutoLoader/pkg-descr b/devel/p5-AutoLoader/pkg-descr
new file mode 100644
index 00000000000..c337d2feca0
--- /dev/null
+++ b/devel/p5-AutoLoader/pkg-descr
@@ -0,0 +1,5 @@
+The AutoLoader module works with the AutoSplit module and the "__END__"
+token to defer the loading of some subroutines until they are used
+rather than loading them all at once.
+
+WWW: http://search.cpan.org/dist/AutoLoader/
diff --git a/devel/p5-AutoLoader/pkg-plist b/devel/p5-AutoLoader/pkg-plist
new file mode 100644
index 00000000000..6b5843ce361
--- /dev/null
+++ b/devel/p5-AutoLoader/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/AutoLoader.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/AutoLoader/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/AutoLoader