aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorgabor <gabor@FreeBSD.org>2007-02-25 23:03:47 +0800
committergabor <gabor@FreeBSD.org>2007-02-25 23:03:47 +0800
commit047fbb301aaaae5a72983a301083546ef1b113f5 (patch)
tree3afb9daa683c03bb5550bd7253dd0448066b7138
parent50e15f56f0f1a504104c29468445b49e267b6bf4 (diff)
downloadfreebsd-ports-graphics-047fbb301aaaae5a72983a301083546ef1b113f5.tar.gz
freebsd-ports-graphics-047fbb301aaaae5a72983a301083546ef1b113f5.tar.zst
freebsd-ports-graphics-047fbb301aaaae5a72983a301083546ef1b113f5.zip
POE::Component::Server::DNS is a POE component that implements a DNS server.
It uses POE::Component::Client::DNS to handle resolving when configured as 'forward_only' and Net::DNS::Resolver::Recurse wrapped by POE::Component::Generic to perform recursion. One may add handlers to massage and manipulate responses to particular queries which is vaguely modelled after Net::DNS::Nameserver. WWW: http://search.cpan.org/dist/POE-Component-Server-DNS/ PR: ports/109449 Submitted by: Jin-Shan Tseng <tjs at cdpa.nsysu.edu.tw> Approved by: erwin (mentor, implicit)
-rw-r--r--dns/Makefile1
-rw-r--r--dns/p5-POE-Component-Server-DNS/Makefile27
-rw-r--r--dns/p5-POE-Component-Server-DNS/distinfo3
-rw-r--r--dns/p5-POE-Component-Server-DNS/pkg-descr10
-rw-r--r--dns/p5-POE-Component-Server-DNS/pkg-plist10
5 files changed, 51 insertions, 0 deletions
diff --git a/dns/Makefile b/dns/Makefile
index a8ebaa88674..81f180463d8 100644
--- a/dns/Makefile
+++ b/dns/Makefile
@@ -89,6 +89,7 @@
SUBDIR += p5-Net-Nslookup
SUBDIR += p5-Net-RBLClient
SUBDIR += p5-POE-Component-Client-DNS
+ SUBDIR += p5-POE-Component-Server-DNS
SUBDIR += p5-Stanford-DNSserver
SUBDIR += p5-Tie-DNS
SUBDIR += pdnsd
diff --git a/dns/p5-POE-Component-Server-DNS/Makefile b/dns/p5-POE-Component-Server-DNS/Makefile
new file mode 100644
index 00000000000..24fe4527c09
--- /dev/null
+++ b/dns/p5-POE-Component-Server-DNS/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: p5-POE-Component-Server-DNS
+# Date created: 2007-02-23
+# Whom: Jin-Shan Tseng <tjs@cdpa.nsysu.edu.tw>
+#
+# $FreeBSD$
+#
+
+PORTNAME= POE-Component-Server-DNS
+PORTVERSION= 0.05
+CATEGORIES= dns perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= POE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tjs@cdpa.nsysu.edu.tw
+COMMENT= Non-blocking, concurrent DNS server component
+
+RUN_DEPENDS= p5-POE>=0.38:${PORTSDIR}/devel/p5-POE \
+ p5-Net-DNS>=0.58:${PORTSDIR}/dns/p5-Net-DNS \
+ p5-POE-Component-Client-DNS>=1.00:${PORTSDIR}/dns/p5-POE-Component-Client-DNS \
+ p5-POE-Component-Generic>=0.09.10:${PORTSDIR}/net/p5-POE-Component-Generic
+
+PERL_CONFIGURE= yes
+
+MAN3= POE::Component::Server::DNS.3
+
+.include <bsd.port.mk>
diff --git a/dns/p5-POE-Component-Server-DNS/distinfo b/dns/p5-POE-Component-Server-DNS/distinfo
new file mode 100644
index 00000000000..dcdab253c97
--- /dev/null
+++ b/dns/p5-POE-Component-Server-DNS/distinfo
@@ -0,0 +1,3 @@
+MD5 (POE-Component-Server-DNS-0.05.tar.gz) = 89032f83fe50ea2b8eadd990c05ce903
+SHA256 (POE-Component-Server-DNS-0.05.tar.gz) = 60120736dcbe6807fd07fbe95f832ae162803add10121ee00f7c1c4c6be7ad9c
+SIZE (POE-Component-Server-DNS-0.05.tar.gz) = 17265
diff --git a/dns/p5-POE-Component-Server-DNS/pkg-descr b/dns/p5-POE-Component-Server-DNS/pkg-descr
new file mode 100644
index 00000000000..35a86cc2deb
--- /dev/null
+++ b/dns/p5-POE-Component-Server-DNS/pkg-descr
@@ -0,0 +1,10 @@
+POE::Component::Server::DNS is a POE component that implements a DNS server.
+
+It uses POE::Component::Client::DNS to handle resolving when configured as
+'forward_only' and Net::DNS::Resolver::Recurse wrapped by
+POE::Component::Generic to perform recursion.
+
+One may add handlers to massage and manipulate responses to particular queries
+which is vaguely modelled after Net::DNS::Nameserver.
+
+WWW: http://search.cpan.org/dist/POE-Component-Server-DNS/
diff --git a/dns/p5-POE-Component-Server-DNS/pkg-plist b/dns/p5-POE-Component-Server-DNS/pkg-plist
new file mode 100644
index 00000000000..d5985f8c17c
--- /dev/null
+++ b/dns/p5-POE-Component-Server-DNS/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/DNS/.packlist
+%%SITE_PERL%%/POE/Component/Server/DNS.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server/DNS
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component/Server
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE/Component
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/POE
+@dirrmtry %%SITE_PERL%%/POE/Component/Server
+@dirrmtry %%SITE_PERL%%/POE/Component
+@dirrmtry %%SITE_PERL%%/POE