diff options
author | pgj <pgj@FreeBSD.org> | 2013-03-31 21:43:10 +0800 |
---|---|---|
committer | pgj <pgj@FreeBSD.org> | 2013-03-31 21:43:10 +0800 |
commit | 08a74aeb97d872029fd01d2ccedc534a3eec4181 (patch) | |
tree | 706535a9ca9e2f059790de4fce1e4edf8c756239 | |
parent | 6b756ea445d5bb32725589d2878cb7b5bc3ad4f6 (diff) | |
download | freebsd-ports-graphics-08a74aeb97d872029fd01d2ccedc534a3eec4181.tar.gz freebsd-ports-graphics-08a74aeb97d872029fd01d2ccedc534a3eec4181.tar.zst freebsd-ports-graphics-08a74aeb97d872029fd01d2ccedc534a3eec4181.zip |
- Fix a minor dynamic linking problem for certain Haskell Cabal ports
- Add an UPDATING entry for description and instructions
Submitted by: ashish
Approved by: portmgr (miwi)
Obtained from: FreeBSD Haskell
-rw-r--r-- | UPDATING | 15 | ||||
-rw-r--r-- | devel/hs-BNFC/Makefile | 1 | ||||
-rw-r--r-- | devel/hs-uuagc/Makefile | 2 | ||||
-rw-r--r-- | lang/ghc/bsd.cabal.mk | 1 | ||||
-rw-r--r-- | math/hs-Agda/Makefile | 1 | ||||
-rw-r--r-- | textproc/hs-pandoc/Makefile | 1 |
6 files changed, 20 insertions, 1 deletions
@@ -5,6 +5,21 @@ they are unavoidable. You should get into the habit of checking this file for changes each time you update your ports collection, before attempting any port upgrades. +20130331: + AFFECTS: users of */hs-* + AUTHOR: haskell@FreeBSD.org + + Due to some unexpected dynamic linking problems, Haskell Cabal ports with + binaries that link to their own libraries may not work. With default + configuration, the following ports are known to have this problem: + Agda, BNFC, pandoc, and uuagc. (Their port revision are now bumped.) + + In general, it is recommended to rebuild the port if you are + experiencing that the corresponding binary will not start, e.g.: + + % agda + Shared object "libHSAgda-2.3.2-ghc7.4.2.so" not found, required by "agda" + 20130329: AFFECTS: users of ports-mgmt/portmaster AUTHOR: bdrewery@FreeBSD.org diff --git a/devel/hs-BNFC/Makefile b/devel/hs-BNFC/Makefile index 2703847e069..a8dfbb5c72e 100644 --- a/devel/hs-BNFC/Makefile +++ b/devel/hs-BNFC/Makefile @@ -3,6 +3,7 @@ PORTNAME= BNFC PORTVERSION= 2.6.0.3 +PORTREVISION= 1 CATEGORIES= devel haskell MAINTAINER= haskell@FreeBSD.org diff --git a/devel/hs-uuagc/Makefile b/devel/hs-uuagc/Makefile index 579e8b73035..e28d4f5dd5d 100644 --- a/devel/hs-uuagc/Makefile +++ b/devel/hs-uuagc/Makefile @@ -3,7 +3,7 @@ PORTNAME= uuagc PORTVERSION= 0.9.42.2 -PORTREVISION= 2 +PORTREVISION= 3 CATEGORIES= devel haskell MAINTAINER= haskell@FreeBSD.org diff --git a/lang/ghc/bsd.cabal.mk b/lang/ghc/bsd.cabal.mk index 107dda7a3b3..59978dc20a7 100644 --- a/lang/ghc/bsd.cabal.mk +++ b/lang/ghc/bsd.cabal.mk @@ -174,6 +174,7 @@ CONFIGURE_ARGS+= --haddock-options=-w --with-haddock=${HADDOCK_CMD} .if ${PORT_OPTIONS:MDYNAMIC} CONFIGURE_ARGS+= --enable-shared --enable-executable-dynamic +CONFIGURE_ARGS+= "--ghc-option=-optl -rpath" "--ghc-option=-optl ${CABAL_LIBDIR}/${DISTNAME}" .else CONFIGURE_ARGS+= --disable-shared --disable-executable-dynamic .endif diff --git a/math/hs-Agda/Makefile b/math/hs-Agda/Makefile index d86e179601d..fe2428fe19e 100644 --- a/math/hs-Agda/Makefile +++ b/math/hs-Agda/Makefile @@ -3,6 +3,7 @@ PORTNAME= Agda PORTVERSION= 2.3.2 +PORTREVISION= 1 CATEGORIES= math haskell MAINTAINER= haskell@FreeBSD.org diff --git a/textproc/hs-pandoc/Makefile b/textproc/hs-pandoc/Makefile index 0003ff03c21..539cee27513 100644 --- a/textproc/hs-pandoc/Makefile +++ b/textproc/hs-pandoc/Makefile @@ -3,6 +3,7 @@ PORTNAME= pandoc PORTVERSION= 1.11.1 +PORTREVISION= 1 CATEGORIES= textproc haskell MAINTAINER= haskell@FreeBSD.org |