aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortg <tg@FreeBSD.org>1997-11-17 21:18:37 +0800
committertg <tg@FreeBSD.org>1997-11-17 21:18:37 +0800
commit097a7be4d75626043232dbdea9ee1cf5dfcf73ef (patch)
tree5a94a4073041017ee15cdbfb4c968b8b602cf7c3
parentf23e6147247f2e6430c24c9d272f4ec7f727caf1 (diff)
downloadfreebsd-ports-graphics-097a7be4d75626043232dbdea9ee1cf5dfcf73ef.tar.gz
freebsd-ports-graphics-097a7be4d75626043232dbdea9ee1cf5dfcf73ef.tar.zst
freebsd-ports-graphics-097a7be4d75626043232dbdea9ee1cf5dfcf73ef.zip
Import lftp port. lftp is a shell-like command line FTP client which
can perform tasks in background. Other features include reput and mirror. PR: 4510 Submitted by: Andrey Zakhvatov <andy@icc.surw.chel.su>
-rw-r--r--ftp/lftp/Makefile30
-rw-r--r--ftp/lftp/distinfo1
-rw-r--r--ftp/lftp/pkg-comment1
-rw-r--r--ftp/lftp/pkg-descr10
-rw-r--r--ftp/lftp/pkg-plist11
5 files changed, 53 insertions, 0 deletions
diff --git a/ftp/lftp/Makefile b/ftp/lftp/Makefile
new file mode 100644
index 00000000000..3ce9c1b6368
--- /dev/null
+++ b/ftp/lftp/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: lftp
+# Version required: 0.12.2
+# Date created: 11 September 1997
+# Whom: Andrey Zakhvatov
+#
+# $Id$
+#
+
+DISTNAME= lftp-0.12.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= system/network/file-transfer
+
+MAINTAINER= andy@icc.surw.chel.su
+
+GNU_CONFIGURE= yes
+MAN1= lftp.1 ftpget.1 parallelftp.1
+
+do-install:
+.for file in lftp ftpget parallelftp
+ @ ${INSTALL_PROGRAM} ${WRKSRC}/src/${file} ${PREFIX}/bin
+ @ ${INSTALL_MAN} ${WRKSRC}/doc/${file}.1 ${PREFIX}/man/man1
+.endfor
+ @ ${INSTALL_DATA} ${WRKSRC}/lftp.conf ${PREFIX}/etc/lftp.conf
+ @ ${MKDIR} ${PREFIX}/share/doc/lftp
+.for file in NEWS README TODO
+ @ ${INSTALL_DATA} ${WRKSRC}/${file} ${PREFIX}/share/doc/lftp
+.endfor
+
+.include <bsd.port.mk>
diff --git a/ftp/lftp/distinfo b/ftp/lftp/distinfo
new file mode 100644
index 00000000000..95e499749e4
--- /dev/null
+++ b/ftp/lftp/distinfo
@@ -0,0 +1 @@
+MD5 (lftp-0.12.2.tar.gz) = fb3cdfd81458e36130401e9ad63b020e
diff --git a/ftp/lftp/pkg-comment b/ftp/lftp/pkg-comment
new file mode 100644
index 00000000000..a2199e63744
--- /dev/null
+++ b/ftp/lftp/pkg-comment
@@ -0,0 +1 @@
+Shell-like command line ftp client
diff --git a/ftp/lftp/pkg-descr b/ftp/lftp/pkg-descr
new file mode 100644
index 00000000000..3948df1e5c2
--- /dev/null
+++ b/ftp/lftp/pkg-descr
@@ -0,0 +1,10 @@
+ LFTP is a shell-like command line ftp client.
+ The main two advantages over other ftp clients are reliability
+and ability to perform tasks in background. It will reconnect and
+reget the file being transferred if the connection broke.
+ You can start a transfer in background and continue browsing
+on the ftp site. It does this all in one process. When you have
+started background jobs and feel you are done, you can just exit
+lftp and it automatically moves to nohup mode and completes the
+transfers.
+ It has also such nice features as reput and mirror.
diff --git a/ftp/lftp/pkg-plist b/ftp/lftp/pkg-plist
new file mode 100644
index 00000000000..3a856f663d5
--- /dev/null
+++ b/ftp/lftp/pkg-plist
@@ -0,0 +1,11 @@
+bin/lftp
+bin/ftpget
+bin/parallelftp
+etc/lftp.conf
+man/man1/lftp.1.gz
+man/man1/ftpget.1.gz
+man/man1/parallelftp.1.gz
+share/doc/lftp/NEWS
+share/doc/lftp/README
+share/doc/lftp/TODO
+@dirrm share/doc/lftp