aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2002-09-09 12:57:29 +0800
committermarcus <marcus@FreeBSD.org>2002-09-09 12:57:29 +0800
commit099fbf5e97ea52f72c1fb56dac76e0d68228800d (patch)
tree022f637c57fa98d7afa87129681e42cd61e6473e
parent49b9775ac84c0d5c1f2aadd56bb5d8b3183e10b8 (diff)
downloadfreebsd-ports-graphics-099fbf5e97ea52f72c1fb56dac76e0d68228800d.tar.gz
freebsd-ports-graphics-099fbf5e97ea52f72c1fb56dac76e0d68228800d.tar.zst
freebsd-ports-graphics-099fbf5e97ea52f72c1fb56dac76e0d68228800d.zip
Fix things after the recent GNOMENG commit.
Submitted by: bento
-rw-r--r--audio/gnapster/Makefile15
1 files changed, 7 insertions, 8 deletions
diff --git a/audio/gnapster/Makefile b/audio/gnapster/Makefile
index 6e7ed57a3d5..34adbd8ae8c 100644
--- a/audio/gnapster/Makefile
+++ b/audio/gnapster/Makefile
@@ -15,26 +15,25 @@ MAINTAINER= cpiazza@FreeBSD.org
USE_GMAKE= yes
USE_X_PREFIX= yes
USE_GNOMENG= yes
+USE_GNOME= imlib
WANT_GNOME= yes
USE_LIBTOOL= yes
+USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -L${X11BASE}/lib"
.include <bsd.port.pre.mk>
-.if ${HAVE_GNOME:Mimlib}!=""
-USE_GNOME= imlib
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+USE_GNOME+= gnomehack gnomelibs
CONFIGURE_ARGS+= --datadir=${PREFIX}/share
-PKGNAMESUFFIX= -imlib
+PKGNAMESUFFIX= -gnome
.else
CONFIGURE_ARGS+=--disable-gnome --disable-gdk-pixbuf
.endif
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
.include <bsd.port.post.mk>