aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2001-01-04 07:38:33 +0800
committerwill <will@FreeBSD.org>2001-01-04 07:38:33 +0800
commit0b0c9707a0b6969cdda44ee92ececb85db52563d (patch)
tree087f2380c74064694a388181916463cf4f62278a
parent8a4d82b9f31e9bf35e928efbd4e09458674aa5ea (diff)
downloadfreebsd-ports-graphics-0b0c9707a0b6969cdda44ee92ececb85db52563d.tar.gz
freebsd-ports-graphics-0b0c9707a0b6969cdda44ee92ececb85db52563d.tar.zst
freebsd-ports-graphics-0b0c9707a0b6969cdda44ee92ececb85db52563d.zip
Add p5-Math-Bezier 0.01, perl module to solve Bezier curves.
-rw-r--r--math/Makefile1
-rw-r--r--math/p5-Math-Bezier/Makefile23
-rw-r--r--math/p5-Math-Bezier/distinfo1
-rw-r--r--math/p5-Math-Bezier/pkg-comment1
-rw-r--r--math/p5-Math-Bezier/pkg-descr3
-rw-r--r--math/p5-Math-Bezier/pkg-plist3
6 files changed, 32 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 63c289697ce..6970d6bb456 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -48,6 +48,7 @@
SUBDIR += p5-AI-Perceptron
SUBDIR += p5-Bit-ShiftReg
SUBDIR += p5-Bit-Vector
+ SUBDIR += p5-Math-Bezier
SUBDIR += p5-Math-Expr
SUBDIR += p5-Math-Logic
SUBDIR += p5-MatrixReal
diff --git a/math/p5-Math-Bezier/Makefile b/math/p5-Math-Bezier/Makefile
new file mode 100644
index 00000000000..cf1371844df
--- /dev/null
+++ b/math/p5-Math-Bezier/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: Math-Bezier
+# Date created: Wed Jan 3 10:40:02 2001
+# Whom: will
+#
+# $FreeBSD$
+#
+
+PORTNAME= Math-Bezier
+PORTVERSION= 0.01
+CATEGORIES= math perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Math
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= ports@FreeBSD.org
+
+USE_PERL5= yes
+PERL_CONFIGURE= yes
+
+MANPREFIX= ${PREFIX}/lib/perl5/${PERL_VERSION}
+MAN3= Math::Bezier.3
+
+.include <bsd.port.mk>
diff --git a/math/p5-Math-Bezier/distinfo b/math/p5-Math-Bezier/distinfo
new file mode 100644
index 00000000000..86672072e3f
--- /dev/null
+++ b/math/p5-Math-Bezier/distinfo
@@ -0,0 +1 @@
+MD5 (Math-Bezier-0.01.tar.gz) = ba6874d8754e2d64ab9c7d15e0eb56c2
diff --git a/math/p5-Math-Bezier/pkg-comment b/math/p5-Math-Bezier/pkg-comment
new file mode 100644
index 00000000000..52bf47fa010
--- /dev/null
+++ b/math/p5-Math-Bezier/pkg-comment
@@ -0,0 +1 @@
+Perl module to solve Bezier curves
diff --git a/math/p5-Math-Bezier/pkg-descr b/math/p5-Math-Bezier/pkg-descr
new file mode 100644
index 00000000000..93a63946473
--- /dev/null
+++ b/math/p5-Math-Bezier/pkg-descr
@@ -0,0 +1,3 @@
+Math::Bezier is a perl interface to solve Bezier curves.
+
+--will
diff --git a/math/p5-Math-Bezier/pkg-plist b/math/p5-Math-Bezier/pkg-plist
new file mode 100644
index 00000000000..4b050e79104
--- /dev/null
+++ b/math/p5-Math-Bezier/pkg-plist
@@ -0,0 +1,3 @@
+lib/perl5/site_perl/%%PERL_VER%%/Math/Bezier.pm
+lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Bezier/.packlist
+@dirrm lib/perl5/site_perl/%%PERL_VER%%/%%PERL_ARCH%%/auto/Math/Bezier