aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-17 14:51:04 +0800
committerbapt <bapt@FreeBSD.org>2013-09-17 14:51:04 +0800
commit0d179b7daca5221c9055d9a0c434f87ec3405750 (patch)
treef134d7bf940f5f50482b60e36c255e9f239360d6
parent9ff37d19d6ac3b540a4597b1a399fc17a26f4635 (diff)
downloadfreebsd-ports-graphics-0d179b7daca5221c9055d9a0c434f87ec3405750.tar.gz
freebsd-ports-graphics-0d179b7daca5221c9055d9a0c434f87ec3405750.tar.zst
freebsd-ports-graphics-0d179b7daca5221c9055d9a0c434f87ec3405750.zip
Convert to new perl framework
Convert from USE_GMAKE to USES=gmake
-rw-r--r--lang/clang/Makefile9
-rw-r--r--lang/clang31/Makefile9
-rw-r--r--lang/erlang/Makefile11
-rw-r--r--lang/gcc/Makefile4
-rw-r--r--lang/gcc47/Makefile4
-rw-r--r--lang/p5-Test-XPath/Makefile3
-rw-r--r--lang/qscheme/Makefile10
-rw-r--r--net-im/jabberd/Makefile4
-rw-r--r--net-im/libpurple/Makefile2
-rw-r--r--net-im/ttytter/Makefile3
-rw-r--r--net-p2p/uhub/Makefile10
-rw-r--r--textproc/confetti/Makefile3
-rw-r--r--textproc/docproj/Makefile3
-rw-r--r--textproc/latex2html/Makefile8
-rw-r--r--textproc/openfts/Makefile9
-rw-r--r--textproc/p5-FormValidator-Lite/Makefile3
-rw-r--r--textproc/p5-Text-VimColor/Makefile3
-rw-r--r--textproc/texi2html/Makefile9
-rw-r--r--textproc/uim/Makefile4
19 files changed, 42 insertions, 69 deletions
diff --git a/lang/clang/Makefile b/lang/clang/Makefile
index 42bf4569036..f1746f240d9 100644
--- a/lang/clang/Makefile
+++ b/lang/clang/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clang
-# Date created: 24 Oct 2009
-# Whom: Brooks Davis
-#
+# Created by: Brooks Davis
# $FreeBSD$
-#
PORTNAME= clang
PORTVERSION= 3.2
@@ -36,9 +32,8 @@ BUILD_DEPENDS+= runtest:${PORTSDIR}/misc/dejagnu
.endif
GNU_CONFIGURE= yes
-USE_GMAKE= yes
+USES= gmake perl5
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_PYTHON= yes
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/${RELTYPE}/bin/clang-tblgen \
diff --git a/lang/clang31/Makefile b/lang/clang31/Makefile
index 2cdadb31ac6..a12217f9730 100644
--- a/lang/clang31/Makefile
+++ b/lang/clang31/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: clang
-# Date created: 24 Oct 2009
-# Whom: Brooks Davis
-#
+# Created by: Brooks Davis
# $FreeBSD$
-#
PORTNAME= clang31
PORTVERSION= 3.1
@@ -38,10 +34,9 @@ BUILD_DEPENDS+= f2c:${PORTSDIR}/lang/f2c
.endif
GNU_CONFIGURE= yes
+USES= gmake perl5
USE_GCC= 4.2+
-USE_GMAKE= yes
USE_LDCONFIG= yes
-USE_PERL5= yes
USE_PYTHON= yes
MAKE_ARGS= CLANG_TBLGEN=${WRKSRC}/${RELTYPE}/bin/clang-tblgen \
diff --git a/lang/erlang/Makefile b/lang/erlang/Makefile
index 5dff97e1d6a..5112a047359 100644
--- a/lang/erlang/Makefile
+++ b/lang/erlang/Makefile
@@ -51,6 +51,11 @@ OPTIONS_DEFAULT=SMP OPENSSL THREADS SCTP KQUEUE
ERL_RELEASE= R${PORTVERSION:S/.//g:U:S/1$/-1/}
+USES= gmake perl5
+USE_CSTD= gnu89
+USE_RC_SUBR= epmd
+GNU_CONFIGURE= yes
+
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MDOCS}
@@ -124,12 +129,6 @@ WX_UNICODE= yes
CONFIGURE_ARGS+=--with-wx-config=${WX_CONFIG}
.endif
-USE_GMAKE= yes
-USE_CSTD= gnu89
-USE_PERL5= yes
-USE_RC_SUBR= epmd
-GNU_CONFIGURE= yes
-
.if ${PORT_OPTIONS:MODBC}
CONFIGURE_ARGS+=--with-odbc
.if ${PORT_OPTIONS:MUNIXODBC}
diff --git a/lang/gcc/Makefile b/lang/gcc/Makefile
index 6659120e34f..7a704e9d248 100644
--- a/lang/gcc/Makefile
+++ b/lang/gcc/Makefile
@@ -28,10 +28,10 @@ DISTVERSION= ${PORTVERSION}
GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
ONLY_FOR_ARCHS= amd64 i386 ia64 powerpc sparc64
-USES= bison gmake iconv
+USES= bison gmake iconv perl5
USE_BINUTILS= yes
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/lang/gcc47/Makefile b/lang/gcc47/Makefile
index 8d5328bdfe2..3726df56e8a 100644
--- a/lang/gcc47/Makefile
+++ b/lang/gcc47/Makefile
@@ -29,10 +29,10 @@ GCC_VERSION= ${PORTVERSION:C/(.+)\.[0-9]{8}/\1/}
SUFFIX= ${PORTVERSION:C/([0-9]+).([0-9]+).*/\1\2/}
LATEST_LINK= gcc${SUFFIX}${PKGNAMESUFFIX}
ONLY_FOR_ARCHS= amd64 i386 powerpc powerpc64 sparc64
-USES= bison gmake iconv
+USES= bison gmake iconv perl5
USE_BINUTILS= yes
USE_BZIP2= yes
-USE_PERL5_BUILD=yes
+USE_PERL5= build
PATCH_WRKSRC= ${SRCDIR}
CONFIGURE_SCRIPT= ../${SRCDIR:S/${WRKDIR}\///}/configure
diff --git a/lang/p5-Test-XPath/Makefile b/lang/p5-Test-XPath/Makefile
index 9b41cb188d3..01662043d6d 100644
--- a/lang/p5-Test-XPath/Makefile
+++ b/lang/p5-Test-XPath/Makefile
@@ -15,7 +15,8 @@ LICENSE_COMB= dual
RUN_DEPENDS= p5-XML-LibXML>=1.70:${PORTSDIR}/textproc/p5-XML-LibXML
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= Test::XPath.3
diff --git a/lang/qscheme/Makefile b/lang/qscheme/Makefile
index 5d4004ac37a..619fdfaa4f2 100644
--- a/lang/qscheme/Makefile
+++ b/lang/qscheme/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: qscheme
-# Date created: 6 Dec 2001
-# Whom: erik@smluc.org
-#
+# Created by: erik@smluc.org
# $FreeBSD$
-#
PORTNAME= qscheme
PORTVERSION= 0.5.1
@@ -19,9 +15,9 @@ BUILD_DEPENDS= ${LOCALBASE}/lib/libavcall.a:${PORTSDIR}/devel/ffcall\
${LOCALBASE}/lib/libgmp.a:${PORTSDIR}/math/gmp
LIB_DEPENDS= getline:${PORTSDIR}/devel/libgetline
-USE_PERL5_BUILD= yes
+USES= gmake perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
-USE_GMAKE= yes
PLIST_SUB+= PORTVERSION="${PORTVERSION}"
CONFIGURE_ARGS= --with-pcre-dir=${LOCALBASE}/lib \
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 6189ca68659..9bdc2aeffed 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -28,9 +28,9 @@ CYRUS_DESC= Use Cyrus SASL backend (not supported)
USE_XZ= yes
GNU_CONFIGURE= yes
-USE_PERL5_RUN= yes
+USE_PERL5= run
USE_OPENSSL= yes
-USES= iconv
+USES= iconv perl5
USE_RC_SUBR= jabberd
USE_LDCONFIG= ${PREFIX}/lib/jabberd
CONFIGURE_ARGS+= --localstatedir=/var \
diff --git a/net-im/libpurple/Makefile b/net-im/libpurple/Makefile
index d52f08913b6..09fa4b95dae 100644
--- a/net-im/libpurple/Makefile
+++ b/net-im/libpurple/Makefile
@@ -194,7 +194,7 @@ PLIST_SUB+= DBUS="@comment not installed: "
.endif
.if ${PORT_OPTIONS:MPERL}
-USE_PERL5= yes
+USES+= perl5
CONFIGURE_ARGS+= --with-perl-lib=site
PLIST_SUB+= PERL:=""
.if !defined(PIDGIN_SLAVE)
diff --git a/net-im/ttytter/Makefile b/net-im/ttytter/Makefile
index d1178f3888c..3e25522b578 100644
--- a/net-im/ttytter/Makefile
+++ b/net-im/ttytter/Makefile
@@ -21,7 +21,8 @@ RUN_DEPENDS= curl:${PORTSDIR}/ftp/curl \
p5-TimeDate>=0:${PORTSDIR}/devel/p5-TimeDate
NO_BUILD= yes
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
OPTIONS_DEFINE= READLINE RLTTYTTER
OPTIONS_DEFAULT=READLINE
diff --git a/net-p2p/uhub/Makefile b/net-p2p/uhub/Makefile
index 96d235259b4..b14f0317949 100644
--- a/net-p2p/uhub/Makefile
+++ b/net-p2p/uhub/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: uhub
-# Date created: 16 Oct 2009
-# Whom: Yashin Dmitry <yashin.dm@gmail.com>
-#
+# Created by: Yashin Dmitry <yashin.dm@gmail.com>
# $FreeBSD$
-#
PORTNAME= uhub
PORTVERSION= 0.4.0
@@ -16,8 +12,8 @@ COMMENT= High performance peer-to-peer hub for the ADC network
LICENSE= GPLv3
-USE_PERL5_BUILD=yes
-USE_GMAKE= yes
+USES= gmake perl5
+USE_PERL5= build
USE_SQLITE= yes
USE_RC_SUBR= uhub
diff --git a/textproc/confetti/Makefile b/textproc/confetti/Makefile
index bad2448a838..0d50f4cb6ef 100644
--- a/textproc/confetti/Makefile
+++ b/textproc/confetti/Makefile
@@ -13,8 +13,7 @@ BUILD_DEPENDS= ${LOCALBASE}/bin/flex:${PORTSDIR}/textproc/flex
USE_BZIP2= yes
USE_GMAKE= yes
-USES= bison
-USE_PERL5= yes
+USES= bison perl5
DATE= 20120801
MAKE_ARGS+= FLEX=${LOCALBASE}/bin/flex
MAKE_JOBS_UNSAFE=yes
diff --git a/textproc/docproj/Makefile b/textproc/docproj/Makefile
index 6045ea9ce61..92098873a11 100644
--- a/textproc/docproj/Makefile
+++ b/textproc/docproj/Makefile
@@ -12,7 +12,8 @@ EXTRACT_ONLY= # empty
MAINTAINER= doceng@FreeBSD.org
COMMENT= The "meta-port" for the FreeBSD Documentation Project
-USE_PERL5_RUN= yes
+USES= perl5
+USE_PERL5= run
# This dependency list should be kept in sync with the list of
# required ports in src/release/Makefile.inc.docports.
diff --git a/textproc/latex2html/Makefile b/textproc/latex2html/Makefile
index 8b6f2b47ffa..d3acfc73509 100644
--- a/textproc/latex2html/Makefile
+++ b/textproc/latex2html/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: latex2html
-# Date created: 3 May 1998
-# Whom: brett@peloton.physics.montana.edu
-#
+# Created by: brett@peloton.physics.montana.edu
# $FreeBSD$
-#
PORTNAME= latex2html
PORTVERSION= 2008
@@ -21,7 +17,7 @@ RUN_DEPENDS:= ${BUILD_DEPENDS}
CONFLICTS= ja-latex2html-[0-9]*
-USE_PERL5= yes
+USES= perl5
USE_GHOSTSCRIPT= yes
USE_TEX= latex dvipsk
GNU_CONFIGURE= yes
diff --git a/textproc/openfts/Makefile b/textproc/openfts/Makefile
index ae3354de692..38de1c42aca 100644
--- a/textproc/openfts/Makefile
+++ b/textproc/openfts/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OpenFTS
-# Date Created: 15 Aug, 2003
-# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
-#
+# Created by: Jun Kuriyama <kuriyama@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= openfts
PORTVERSION= 0.40
@@ -19,7 +15,8 @@ RUN_DEPENDS= ${LOCALBASE}/lib/postgresql/tsearch2.so:${PORTSDIR}/databases/postg
p5-DBD-Pg>=0:${PORTSDIR}/databases/p5-DBD-Pg
USE_PGSQL= yes
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
.include <bsd.port.pre.mk>
diff --git a/textproc/p5-FormValidator-Lite/Makefile b/textproc/p5-FormValidator-Lite/Makefile
index 7354efccd7e..16a92cadbbd 100644
--- a/textproc/p5-FormValidator-Lite/Makefile
+++ b/textproc/p5-FormValidator-Lite/Makefile
@@ -24,7 +24,8 @@ TEST_DEPENDS= p5-Text-TestBase>0:${PORTSDIR}/textproc/p5-Text-TestBase \
p5-Test-Requires>=0.05:${PORTSDIR}/devel/p5-Test-Requires \
p5-YAML>=0:${PORTSDIR}/textproc/p5-YAML
-PERL_MODBUILD= yes
+USES= perl5
+USE_PERL5= modbuild
MAN3= FormValidator::Lite.3 \
FormValidator::Lite::Constraint.3 \
diff --git a/textproc/p5-Text-VimColor/Makefile b/textproc/p5-Text-VimColor/Makefile
index 55dd7f4bef3..623a523516b 100644
--- a/textproc/p5-Text-VimColor/Makefile
+++ b/textproc/p5-Text-VimColor/Makefile
@@ -19,7 +19,8 @@ RUN_DEPENDS= p5-File-ShareDir>=0:${PORTSDIR}/devel/p5-File-ShareDir \
p5-Path-Class>=0:${PORTSDIR}/devel/p5-Path-Class \
${LOCALBASE}/bin/vim:${PORTSDIR}/editors/vim
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN1= text-vimcolor.1
MAN3= Text::VimColor.3
diff --git a/textproc/texi2html/Makefile b/textproc/texi2html/Makefile
index 111325b4229..ce2d33e0817 100644
--- a/textproc/texi2html/Makefile
+++ b/textproc/texi2html/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: texi2html
-# Date created: 5 Nov 1997
-# Whom: Ian Vaudrey <i.vaudrey@bigfoot.com>
-#
+# Created by: Ian Vaudrey <i.vaudrey@bigfoot.com>
# $FreeBSD$
-#
PORTNAME= texi2html
PORTVERSION= 5.0
@@ -18,9 +14,8 @@ COMMENT= Texinfo to HTML converter
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL}
CONFIGURE_ARGS= --disable-multiplatform
+USES= gmake perl5
USE_BZIP2= yes
-USE_PERL5= yes
-USE_GMAKE= yes
OPTIONS_DEFINE= NLS DOCS
diff --git a/textproc/uim/Makefile b/textproc/uim/Makefile
index ae87c430ca5..ef806343328 100644
--- a/textproc/uim/Makefile
+++ b/textproc/uim/Makefile
@@ -17,8 +17,8 @@ USE_LDCONFIG= yes
WANT_GNOME= yes
USE_GNOME+= glib20 intltool
USE_AUTOTOOLS= libtool
-USES= gettext gmake iconv pkgconfig
-USE_PERL5_BUILD=yes
+USES= gettext gmake iconv pkgconfig perl5
+USE_PERL5= build
GNU_CONFIGURE= yes
.if !defined(WITHOUT_X11)