aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpetef <petef@FreeBSD.org>2002-08-11 04:44:15 +0800
committerpetef <petef@FreeBSD.org>2002-08-11 04:44:15 +0800
commit0d9d3844c2d3afb18a07d225a5339f91242f5897 (patch)
treed35a3071656c2114c2ccc7ac7f92b362333f9d6d
parente72bf53114dc0b9cda9fc257d104629a0d268ac8 (diff)
downloadfreebsd-ports-graphics-0d9d3844c2d3afb18a07d225a5339f91242f5897.tar.gz
freebsd-ports-graphics-0d9d3844c2d3afb18a07d225a5339f91242f5897.tar.zst
freebsd-ports-graphics-0d9d3844c2d3afb18a07d225a5339f91242f5897.zip
Add entropy 1.0, calculate data entropy to benchmark compression
algorithms. Submitted by: Chris S.J. Peron <maneo@bsdpro.com>
-rw-r--r--math/Makefile1
-rw-r--r--math/entropy/Makefile18
-rw-r--r--math/entropy/distinfo1
-rw-r--r--math/entropy/pkg-comment1
-rw-r--r--math/entropy/pkg-descr3
-rw-r--r--math/entropy/pkg-plist1
6 files changed, 25 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 927a247275f..d1b6fc5a508 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -24,6 +24,7 @@
SUBDIR += diehard
SUBDIR += djbfft
SUBDIR += eispack
+ SUBDIR += entropy
SUBDIR += eukleides
SUBDIR += eval
SUBDIR += femlab
diff --git a/math/entropy/Makefile b/math/entropy/Makefile
new file mode 100644
index 00000000000..2e3a549a430
--- /dev/null
+++ b/math/entropy/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: entropy
+# Date created: 9 August 2002
+# Whom: Chris S.J. Peron <maneo@bsdpro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= entropy
+PORTVERSION= 1.0
+CATEGORIES= math archivers
+MASTER_SITES= http://staff.seccuris.com/~cperon/
+
+MAINTAINER= maneo@bsdpro.com
+
+MAN1= entropy.1
+MANCOMPRESSED= yes
+
+.include <bsd.port.mk>
diff --git a/math/entropy/distinfo b/math/entropy/distinfo
new file mode 100644
index 00000000000..c714b75b6fb
--- /dev/null
+++ b/math/entropy/distinfo
@@ -0,0 +1 @@
+MD5 (entropy-1.0.tar.gz) = 1369f409983abd88e50221ea36049edb
diff --git a/math/entropy/pkg-comment b/math/entropy/pkg-comment
new file mode 100644
index 00000000000..4e9c2146cbf
--- /dev/null
+++ b/math/entropy/pkg-comment
@@ -0,0 +1 @@
+Calculate data entropy to benchmark compression algorithms
diff --git a/math/entropy/pkg-descr b/math/entropy/pkg-descr
new file mode 100644
index 00000000000..29017039d54
--- /dev/null
+++ b/math/entropy/pkg-descr
@@ -0,0 +1,3 @@
+Entropy is a program that will calculate the entropy of a given set
+of data. This program is mainly used to benchmark the efficiency
+of existing or developing compression algorithms.
diff --git a/math/entropy/pkg-plist b/math/entropy/pkg-plist
new file mode 100644
index 00000000000..61b29c665db
--- /dev/null
+++ b/math/entropy/pkg-plist
@@ -0,0 +1 @@
+bin/entropy