aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2009-07-10 21:30:26 +0800
committerbeat <beat@FreeBSD.org>2009-07-10 21:30:26 +0800
commit1057204e0edb96972042fc693c88757d75714118 (patch)
treed988772e71617e615a2d34cd2cd593905d547453
parentb68f261b3eacbe704b2ba707936e194fb8ddb694 (diff)
downloadfreebsd-ports-graphics-1057204e0edb96972042fc693c88757d75714118.tar.gz
freebsd-ports-graphics-1057204e0edb96972042fc693c88757d75714118.tar.zst
freebsd-ports-graphics-1057204e0edb96972042fc693c88757d75714118.zip
- Allow build on amd64
- Make callgrind dependency optional to allow build on amd64 Reported by: stas via IRC
-rw-r--r--devel/kcachegrind/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/devel/kcachegrind/Makefile b/devel/kcachegrind/Makefile
index 4caf656a442..90d6b0fe2fa 100644
--- a/devel/kcachegrind/Makefile
+++ b/devel/kcachegrind/Makefile
@@ -14,9 +14,7 @@ MASTER_SITE_SUBDIR= kcachegrind
MAINTAINER= beat@FreeBSD.org
COMMENT= Profiling Visualization Tool
-RUN_DEPENDS= callgrind:${PORTSDIR}/devel/callgrind
-
-ONLY_FOR_ARCHS= i386
+ONLY_FOR_ARCHS= i386 amd64
CONFLICTS= kdesdk3-[0-9]*
USE_AUTOTOOLS= libtool:15
@@ -25,7 +23,8 @@ USE_KDELIBS_VER=3
INSTALLS_ICONS= yes
USE_GETTEXT= yes
-OPTIONS= DOT "Use GraphViz/dot to render call graphs" on
+OPTIONS= DOT "Use GraphViz/dot to render call graphs" on \
+ CALLGRIND "Install devel/callgrind" off
.include <bsd.port.pre.mk>
@@ -33,6 +32,10 @@ OPTIONS= DOT "Use GraphViz/dot to render call graphs" on
RUN_DEPENDS+= dot:${PORTSDIR}/graphics/graphviz
.endif
+.if defined (WITH_CALLGRIND)
+RUN_DEPENDS+= callgrind:${PORTSDIR}/devel/callgrind
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
${WRKSRC}/${CONFIGURE_SCRIPT}