aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2016-07-01 17:05:25 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2016-07-01 17:05:25 +0800
commit115a58bc0e9566abe61b469f3c11786f122a1979 (patch)
treea54537525a8cb885b0f418270cf3bae7aa91c95b
parent6d0cb36171c6cc3eae4166d73bb5930b2ad858f1 (diff)
downloadfreebsd-ports-graphics-115a58bc0e9566abe61b469f3c11786f122a1979.tar.gz
freebsd-ports-graphics-115a58bc0e9566abe61b469f3c11786f122a1979.tar.zst
freebsd-ports-graphics-115a58bc0e9566abe61b469f3c11786f122a1979.zip
- Add LICENSE
- Switch to options helpers - Cosmetic fixes
-rw-r--r--devel/swig13/Makefile36
1 files changed, 22 insertions, 14 deletions
diff --git a/devel/swig13/Makefile b/devel/swig13/Makefile
index e1ba00f4323..347ebcdac77 100644
--- a/devel/swig13/Makefile
+++ b/devel/swig13/Makefile
@@ -11,6 +11,10 @@ PKGNAMESUFFIX= 13
MAINTAINER= ports@FreeBSD.org
COMMENT= Simplified Wrapper and Interface Generator
+LICENSE= MIT BSD3CLAUSE
+LICENSE_COMB= multi
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
USES= autoreconf:build
GNU_CONFIGURE= yes
@@ -31,6 +35,8 @@ PORTDOCS= *
PORTEXAMPLES= *
PORTDATA= *
+OCTAVE_VER_CMD= ${LOCALBASE}/bin/octave-config -v 2>/dev/null || ${TRUE}
+
OPTIONS_DEFINE= LUA DOCS EXAMPLES
LUA_DESC= Lua support
@@ -40,26 +46,28 @@ LUA_CONFIGURE_ON= --with-lua=${LUA_BINDIR}/lua \
--with-lualib=${LUA_LIBDIR}
LUA_CONFIGURE_OFF= --without-lua
-OCTAVE_VER_CMD= ${LOCALBASE}/bin/octave-config -v 2>/dev/null || ${TRUE}
-
post-patch:
- ${SETENV} OCTAVE_VER=$$(${OCTAVE_VER_CMD}) \
- ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |; \
- s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
- s|OCTAVEDIR=".*"|OCTAVEDIR="${LOCALBASE}/include/octave-$${OCTAVE_VER}"|; \
- s|MZSCHEME --mute-banner|MZSCHEME|; \
- /^MZDYNOBJ/s|`$$|\| tail -n 1`|; \
- ' ${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
+ @${SETENV} OCTAVE_VER=$$(${OCTAVE_VER_CMD}) \
+ ${REINPLACE_CMD} -e 's|$$RUBY |${RUBY} |; \
+ s|^PHP4CONFIG=.*$$|PHP4CONFIG=php-config|; \
+ s|OCTAVEDIR=".*"|OCTAVEDIR="${LOCALBASE}/include/octave-$${OCTAVE_VER}"|; \
+ s|MZSCHEME --mute-banner|MZSCHEME|; \
+ /^MZDYNOBJ/s|`$$|\| tail -n 1`|; \
+ ' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|malloc.h|stdlib.h|' \
${WRKSRC}/Lib/lua/luarun.swg
post-configure:
- ${REINPLACE_CMD} -e 's#null#&|| true#' ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's#null#&|| true#' ${WRKSRC}/Makefile
post-install:
+ @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
${LN} -f ${STAGEDIR}${PREFIX}/bin/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}${VER}
- cd ${WRKSRC}/Examples && ${COPYTREE_SHARE} '*' ${STAGEDIR}${EXAMPLESDIR}/${PORTVERSION}
- cd ${WRKSRC}/Doc && ${COPYTREE_SHARE} '*' ${STAGEDIR}${DOCSDIR}/${PORTVERSION}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/*
+
+post-install-DOCS-on:
+ cd ${WRKSRC}/Examples && ${COPYTREE_SHARE} . ${STAGEDIR}${EXAMPLESDIR}/${PORTVERSION}
+
+post-install-EXAMPLES-on:
+ cd ${WRKSRC}/Doc && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR}/${PORTVERSION}
.include <bsd.port.mk>